CVE-2026-30960
criticalpriority · track · 0EPSS 0.002 · 10 %ileEUUSEPSS · scored 2026-10-27
rssn is a scientific computing library for Rust, combining a high-performance symbolic computation engine with numerical methods support and physics simulations functionalities. The vulnerability exists in the JIT (Just-In-Time) compilation engine, which is fully exposed via the CFFI (Foreign Function Interface). Due to Improper Input Validation and External Control of Code Generation, an attacker can supply malicious parameters or instruction sequences through the CFFI layer. Since the library often operates with elevated privileges or within high-performance computing contexts, this allows for Arbitrary Code Execution (ACE) at the privilege level of the host process.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · high–critical · 7.6–9.4
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (3)
Products and version ranges known to be affected.
advisories (2)
Vendor and ecosystem advisories describing this.
- GHSA-9c4h-pwmf-m6fjRSSN has Arbitrary Code Execution via Unvalidated JIT Instruction Generation in C-FFI Interface2026-03-10ghsa · osvUS
## Impact **Vulnerability Type**: Improper Control of Generation of Code ('Code Injection') (CWE-94) / Improper Check for Unusual or Exceptional Conditions (CWE-754) / Improper Input Validation (CWE-20) / Use of Low-Level Functionality (CWE-695) / Improper Privilege Management (CWE-269) / External Control of System or Configuration Setting (CWE-15). **Technical Details**: The vulnerability exists in the JIT (Just-In-Time) compilation engine, which is fully exposed via the CFFI (Foreign Function Interface). Due to Improper Input Validation and External Control of Code Generation, an attacker can supply malicious parameters or instruction sequences through the CFFI layer. Since the library often operates with elevated privileges or within high-performance computing contexts, this allows for Arbitrary Code Execution (ACE) at the privilege level of the host process. ## Who is Impacted? * Developers using the library as a dynamic linked library (.so, .dll, .dylib) in multi-language environments (e.g., Python, Node.js, C++). * Cloud Service Providers running the library in multi-tenant environments or automated model-training pipelines. * Users processing untrusted or third-party datasets/models that may trigger malicious JIT instruction generation. Patches * Affected versions: < 0.2.8 * Patched version: 0.2.9 ## Workarounds If you cannot upgrade immediately, please consider the following mitigations: * Strict Sandboxing: Run the library within a restricted sandbox (e.g., WebAssembly, Docker with non-root user, or seccomp profiles) to limit system call access. * Principle of Least Privilege: Ensure the process calling the library does not have administrative or root privileges. * Input Filtering: If possible, implement an application-level validation layer to sanitize any data passed to the CFFI interfaces. * Disable JIT (if applicable): If your workload allows, use the interpreter-only mode (if provided by the library) to bypass the JIT engine entirely. CVSS Score * Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H * Base Score: 9.4 (Critical) ## References [Apich Organization Security Team Homepage](https://security.apich.org/)
- RUSTSEC-2026-0038RustSec Advisory2026-03-08vendor · osvUS
## Impact **Vulnerability Type**: Improper Control of Generation of Code ('Code Injection') (CWE-94) / Improper Check for Unusual or Exceptional Conditions (CWE-754) / Improper Input Validation (CWE-20) / Use of Low-Level Functionality (CWE-695) / Improper Privilege Management (CWE-269) / External Control of System or Configuration Setting (CWE-15). **Technical Details**: The vulnerability exists in the JIT (Just-In-Time) compilation engine, which is fully exposed via the CFFI (Foreign Function Interface). Due to Improper Input Validation and External Control of Code Generation, an attacker can supply malicious parameters or instruction sequences through the CFFI layer. Since the library often operates with elevated privileges or within high-performance computing contexts, this allows for Arbitrary Code Execution (ACE) at the privilege level of the host process. ## Who is Impacted? * Developers using the library as a dynamic linked library (.so, .dll, .dylib) in multi-language environments (e.g., Python, Node.js, C++). * Cloud Service Providers running the library in multi-tenant environments or automated model-training pipelines. * Users processing untrusted or third-party datasets/models that may trigger malicious JIT instruction generation. Patches * Affected versions: < 0.2.8 * Patched version: 0.2.9 ## Workarounds If you cannot upgrade immediately, please consider the following mitigations: * Strict Sandboxing: Run the library within a restricted sandbox (e.g., WebAssembly, Docker with non-root user, or seccomp profiles) to limit system call access. * Principle of Least Privilege: Ensure the process calling the library does not have administrative or root privileges. * Input Filtering: If possible, implement an application-level validation layer to sanitize any data passed to the CFFI interfaces. * Disable JIT (if applicable): If your workload allows, use the interpreter-only mode (if provided by the library) to bypass the JIT engine entirely. ## References [Apich Organization Security Team Homepage](https://security.apich.org/)
also known as (5)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (10)
External citations — patches, advisories, analysis.
- https://github.com/Apich-Organization/rssn/releasesPatchcnnvd
- https://github.com/Apich-Organization/rssn/releases/tag/v0.2.9cnnvd
- https://github.com/Apich-Organization/rssn/security/advisories/GHSA-9c4h-pwmf-m6fjcnnvd
- https://rustsec.org/advisories/RUSTSEC-2026-0038.htmlcnnvd
- https://github.com/Apich-Organization/rssn/releases/tag/v0.2.9enisa_euvd
- https://github.com/Apich-Organization/rssn/security/advisories/GHSA-9c4h-pwmf-m6fjenisa_euvd
- https://rustsec.org/advisories/RUSTSEC-2026-0038.htmlenisa_euvd
- https://github.com/Apich-Organization/rssn/releases/tag/v0.2.9nvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan