CVE-2026-28456
highpriority · track · 0EPSS 0.008 · 56 %ileDEEURUUSEPSS · scored 2026-10-24
OpenClaw versions 2026.1.5 prior to 2026.2.14 contain a vulnerability in the Gateway in which it does not sufficiently constrain configured hook module paths before passing them to dynamic import(), allowing code execution. An attacker with gateway configuration modification access can load and execute unintended local modules in the Node.js process.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6.1–8.6
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (6)
Products and version ranges known to be affected.
advisories (2)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2026-0424OpenClaw: Mehrere SchwachstellenDeutsch2026-02-15csaf · cert_bundDE
Ein Angreifer kann diese Schwachstellen in OpenClaw ausnutzen, um beliebigen Programmcode auszuführen, sich erhöhte Berechtigungen zu verschaffen, Sicherheitsmaßnahmen zu umgehen, Daten zu manipulieren, einen Denial-of-Service-Zustand herbeizuführen, vertrauliche Informationen offenzulegen oder andere, nicht näher bezeichnete Angriffe durchzuführen.
- GHSA-v6c6-vqqg-w888OpenClaw affected by potential code execution via unsafe hook module path handling in Gateway2026-02-18ghsa · osvUS
## Summary OpenClaw Gateway supports hook mappings with optional JavaScript/TypeScript transform modules. In affected versions, the gateway did not sufficiently constrain configured module paths before passing them to dynamic `import()`. Under some configurations, a user who can modify gateway configuration could cause the gateway process to load and execute an unintended local module. ## Impact Potential code execution in the OpenClaw gateway Node.js process. This requires access that can modify gateway configuration (for example via the gateway config endpoints). Treat such access as high privilege. ## Affected Packages / Versions - npm package: `openclaw` - Affected: `>= 2026.1.5` and `<= 2026.2.13` ## Patched Versions - `>= 2026.2.14` ## Fix Commit(s) - `a0361b8ba959e8506dc79d638b6e6a00d12887e4` (restrict hook transform module loading) - `35c0e66ed057f1a9f7ad2515fdcef516bd6584ce` (harden hooks module loading) ## Mitigation - Upgrade to `2026.2.14` or newer. - Avoid exposing gateway configuration endpoints to untrusted networks. - Review config for unsafe values: - `hooks.mappings[].transform.module` - `hooks.internal.handlers[].module` Thanks @222n5 for reporting.
also known as (4)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (13)
External citations — patches, advisories, analysis.
- https://github.com/openclaw/openclaw/commit/35c0e66ed057f1a9f7ad2515fdcef516bd6584cecnnvd
- https://github.com/openclaw/openclaw/commit/a0361b8ba959e8506dc79d638b6e6a00d12887e4cnnvd
- https://github.com/openclaw/openclaw/releasesPatchcnnvd
- https://github.com/openclaw/openclaw/security/advisories/GHSA-v6c6-vqqg-w888cnnvd
- https://www.vulncheck.com/advisories/openclaw-arbitrary-code-execution-via-unsafe-hook-module-path-handlingcnnvd
- https://github.com/openclaw/openclaw/commit/35c0e66ed057f1a9f7ad2515fdcef516bd6584ceenisa_euvd
- https://github.com/openclaw/openclaw/commit/a0361b8ba959e8506dc79d638b6e6a00d12887e4enisa_euvd
- https://github.com/openclaw/openclaw/security/advisories/GHSA-v6c6-vqqg-w888enisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan