CVE-2026-26929
mediumpriority · track · 0EPSS 0.004 · 36 %ileDEEURUUSEPSS · scored 2026-10-27
Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6–7.5
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (7)
Products and version ranges known to be affected.
advisories (4)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2026-0755Apache Airflow: Mehrere SchwachstellenDeutsch2026-03-16csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Apache Airflow ausnutzen, um Sicherheitsvorkehrungen zu umgehen, und um Informationen offenzulegen.
- GHSA-4m3h-wp5w-5hqhApache Airflow: Wildcard DagVersion Listing Bypasses Per‑DAG RBAC and Leaks Metadata2026-03-17ghsa · osvUS
Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
- BIT-airflow-2026-26929Apache Airflow: Wildcard DagVersion Listing Bypasses Per‑DAG RBAC and Leaks Metadata2026-03-18vendor · osvUS
Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
- PYSEC-2026-142026-03-17vendor · osvUS
Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
also known as (8)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (9)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2026/03/17/4cnnvd
- https://airflow.apache.org/Patchcnnvd
- https://github.com/apache/airflow/pull/61675cnnvd
- https://lists.apache.org/thread/g5o6khx83jwqvdyn0mlyb0krt35cs9sscnnvd
- https://github.com/apache/airflow/pull/61675enisa_euvd
- https://lists.apache.org/thread/g5o6khx83jwqvdyn0mlyb0krt35cs9ssenisa_euvd
- http://www.openwall.com/lists/oss-security/2026/03/17/4Mailing ListThird Party Advisorynvd
- https://github.com/apache/airflow/pull/61675Issue Trackingnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan