CVE-2026-21893
highpriority · track · 30EPSS 0.016 · 75 %ileDEEUNLUSEPSS · scored 2026-10-27
n8n is an open source workflow automation platform. From version 0.187.0 to before 1.120.3, a command injection vulnerability was identified in n8n’s community package installation functionality. The issue allowed authenticated users with administrative permissions to execute arbitrary system commands on the n8n host under specific conditions. This issue has been patched in version 1.120.3.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · high–critical · 7.2–9.4
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (10)
Products and version ranges known to be affected.
advisories (3)
Vendor and ecosystem advisories describing this.
- NCSC-2026-0049Kwetsbaarheden verholpen in n8nNL2026-02-09csaf · ncsc_nlNL
n8n heeft kwetsbaarheden verholpen in versies 1.114.3, 1.115.0, 1.123.17, 2.5.2, 1.122.5, 1.123.2, 1.123.18, 2.5.0, 1.123.10, 2.5.0, 2.2.1, 1.123.9, 1.123.12, 2.4.0, 1.118.0, 2.4.0, 2.4.8, en 1.120.3.
- WID-SEC-W-2026-0318n8n: Mehrere SchwachstellenDeutsch2026-02-04csaf · cert_bundDE
Ein entfernter, authentisierter oder anonymer Angreifer kann mehrere Schwachstellen in n8n ausnutzen, um beliebigen Code auszuführen, sich erhöhte Berechtigungen zu verschaffen, Cross-Site-Scripting-Angriffe durchzuführen und vertrauliche Informationen offenzulegen. Über einige dieser Schwachstellen sind weitere Angriffe möglich, wie beispielsweise die Übernahme von Konten, das Hijacking von Sitzungen und die vollständige Kompromittierung des Systems.
- GHSA-7c4h-vh2m-743mn8n Vulnerable to Command Injection in Community Package Installation2026-02-04ghsa · osvUS
### Impact A Command Injection vulnerability was identified in n8n’s community package installation functionality. The issue allowed authenticated users with administrative permissions to execute arbitrary system commands on the n8n host under specific conditions. **Important context** - Exploitation requires _administrative_ access to the n8n instance. - The affected functionality is restricted to trusted users who are already permitted to install third-party community packages. - No unauthenticated or low-privilege exploitation is possible. - There is no evidence of exploitation in the wild. Because administrative users can already extend n8n with custom or community code, the vulnerability does not meaningfully expand the threat model beyond existing administrator capabilities. However, it represents a violation of secure coding practices and has therefore been addressed. ### Patches Users are advised to upgrade to n8n version 1.120.3 or later, which fully resolves the issue. As a general security best practice, n8n instance owners should ensure that: - Administrative access is limited to trusted users only. - Community packages are installed only from trusted sources. - Instances are kept up to date with the latest security releases.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (8)
External citations — patches, advisories, analysis.
- https://access.redhat.com/security/cve/cve-2026-21893cnnvd
- https://github.com/n8n-io/n8n/commit/ae0669a736cc496beeb296e115267862727ae838cnnvd
- https://github.com/n8n-io/n8n/releasesPatchcnnvd
- https://github.com/n8n-io/n8n/security/advisories/GHSA-7c4h-vh2m-743mcnnvd
- https://github.com/n8n-io/n8n/commit/ae0669a736cc496beeb296e115267862727ae838enisa_euvd
- https://github.com/n8n-io/n8n/security/advisories/GHSA-7c4h-vh2m-743menisa_euvd
- https://github.com/n8n-io/n8n/commit/ae0669a736cc496beeb296e115267862727ae838Patchnvd
- https://github.com/n8n-io/n8n/security/advisories/GHSA-7c4h-vh2m-743mVendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan