CVE-2026-112105
lowpriority · track · 15EPSS 0.003 · 22 %ileEPSS · scored 2026-10-27
A vulnerability has been found in GlitterWare Passy up to 1.10.1. The affected element is the function MyHttpOverrides in the library lib/main.dart of the component TLS Handler. Such manipulation leads to improper certificate validation. The attack may be launched remotely. This attack is characterized by high complexity. The exploitability is described as difficult. Upgrading to version 1.10.2 is sufficient to fix this issue. The name of the patch is 3d48df7cce05e39fa4de1e42768492307f26882e. The affected component should be upgraded.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 1.7–6.3
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products
Products and version ranges known to be affected.
No affected products recorded.
sources
Which sources assert this record, and when.
references (8) nvd
External citations — patches, advisories, analysis.
- https://github.com/GlitterWare/Passy/
- https://github.com/GlitterWare/Passy/commit/3d48df7cce05e39fa4de1e42768492307f26882e
- https://github.com/GlitterWare/Passy/issues/210
- https://github.com/GlitterWare/Passy/releases/tag/v1.10.2
- https://vuldb.com/cve/CVE-2026-112105
- https://vuldb.com/submit/1013135
- https://vuldb.com/vuln/422055
- https://vuldb.com/vuln/422055/cti
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan