CVE-2026-105857
criticalpriority · track · 0EPSS 0.004 · 37 %ileUSEPSS · scored 2026-10-27
Payload is a free and open source headless content management system. In @payloadcms/plugin-form-builder versions before 3.90.0 and canary versions before 4.0.0-canary.34, an attacker can craft a form submission that executes code remotely on the server. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (4)
Products and version ranges known to be affected.
- npm @payloadcms/plugin-form-builder4.0.0-canary.0 → 4.0.0-canary.34osvUSpkg:npm/%40payloadcms/plugin-form-builder
advisories (1)
Vendor and ecosystem advisories describing this.
- GHSA-r488-j9vj-wx3qPayload Form Builder has an RCE issue2026-10-07ghsa · osvUS
## Impact A vulnerability in `@payloadcms/plugin-form-builder` in versions < 3.90.0 allow submissions which could be crafted to execute remote code on the server. **You are affected if:** - You are using `@payloadcms/plugin-form-builder` ## Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`.
sources
Which sources assert this record, and when.
references (3) nvd
External citations — patches, advisories, analysis.
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan