CVE-2025-68493

highpriority · attend · 58EPSS 0.458 · 99 %ileexploit · PoCDEEURUUS
grimoire priorityP1 · Urgent
Exploitable?
Public exploit
1 exploit · PoC
Likely / severe?
45.8% (99th) EPSS
CVSS 8.1 · high
Is it mine?
21 products
Check your exposure
Who says so?
6 sources
cnnvd · enisa_euvd · fstec_bdu · cert_bund

EPSS · scored 2026-10-22

Missing XML Validation vulnerability in Apache Struts, Apache Struts. This issue affects Apache Struts: from 2.0.0 before 2.2.1; Apache Struts: from 2.2.1 through 6.1.0. Users are recommended to upgrade to version 6.1.1, which fixes the issue.

01

cvss

Technical severity, 0–10. One row per scoring source.

8.1
010

base score 0–10 · higher = more severe · hover a vector to decode

v3.18.1highCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:Hprimary · NVD / NIST USexploitability 2.8 · impact 5.2
v3.18.1highAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:Hsecondary · FSTEC (BDU) RU
v3.18.1highCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:Hsecondary · ENISA EU
v3.18.1highCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:Hsecondaryexploitability 2.8 · impact 5.2
v3.17.1highCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:Lsecondaryexploitability 2.8 · impact 4.2
v3.18.1highCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:Hsecondary · OSV
v3.18.1highCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H/E:Hsecondary · CVSS-BT (t0sche)
02

ssvc

A stakeholder decision — act, attend, or track — from exploitation and impact.

Trackcoordinatorcisa_ssvcUS
03

weaknesses

The CWE weakness classes this flaw belongs to.

04

exploits (1)

Public proof-of-concept and weaponised exploit code.

05

affected products (21)

Products and version ranges known to be affected.

showing 20 of 21
06

advisories (2)

Vendor and ecosystem advisories describing this.

  • WID-SEC-W-2026-0064Apache Struts (XWork): Schwachstelle ermöglicht Manipulation von DateienDeutsch2026-01-11csaf · cert_bundDE

    Ein Angreifer kann eine Schwachstelle in Apache Struts ausnutzen, um Dateien zu manipulieren, vertrauliche Daten offenzulegen oder einen Denial-of-Service-Zustand zu verursachen.

  • GHSA-qcfc-hmrc-59x7Apache Struts 2 is Missing XML Validation2026-01-11ghsa · osvUS

    Missing XML Validation vulnerability in Apache Struts, Apache Struts. This issue affects Apache Struts: from 2.0.0 before 2.2.1; Apache Struts: from 2.2.1 through 6.1.0. Users are recommended to upgrade to version 6.1.1, which fixes the issue.

07

also known as (4)

Other names and identifiers for this entity.

08

sources

Which sources assert this record, and when.

09

references (10)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan