CVE-2025-66675
highpriority · track · 0EPSS 0.006 · 48 %ileDEEUUSEPSS · scored 2026-10-22
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue. It's related to https://cve.org/CVERecord?id=CVE-2025-64775 - this CVE addresses missing affected version 6.7.4
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (10)
Products and version ranges known to be affected.
advisories (4)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2025-2704Apache Struts: Schwachstelle ermöglicht Denial of ServiceDeutsch2025-12-01csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann eine Schwachstelle in Apache Struts ausnutzen, um einen Denial of Service Angriff durchzuführen.
- WID-SEC-W-2026-0783IBM QRadar SIEM: Mehrere SchwachstellenDeutsch2026-03-18csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in IBM QRadar SIEM ausnutzen, um beliebigen Programmcode auszuführen, um Informationen offenzulegen, um einen Denial of Service Angriff durchzuführen, um einen Cross-Site Scripting Angriff durchzuführen, und um Dateien zu manipulieren.
- WID-SEC-W-2026-1032IBM Tivoli Network Manager: Mehrere SchwachstellenDeutsch2026-04-08csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in IBM Tivoli Network Manager ausnutzen, um beliebigen Programmcode auszuführen, um einen Denial of Service Angriff durchzuführen, um Informationen offenzulegen, und um Sicherheitsvorkehrungen zu umgehen.
- GHSA-rg58-xhh7-mqjwApache Struts has a Denial of Service vulnerability2025-12-10ghsa · osvUS
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (8)
External citations — patches, advisories, analysis.
- https://cve.org/CVERecord?id=CVE-2025-64775cnnvd
- https://cwiki.apache.org/confluence/display/WW/S2-068cnnvd
- https://struts.apache.org/download.cgiPatchcnnvd
- https://vigilance.fr/vulnerability/Apache-Struts-overload-via-Multipart-Request-49048cnnvd
- https://cve.org/CVERecord?id=CVE-2025-64775enisa_euvd
- https://cwiki.apache.org/confluence/display/WW/S2-068enisa_euvd
- https://cve.org/CVERecord?id=CVE-2025-64775Third Party Advisorynvd
- https://cwiki.apache.org/confluence/display/WW/S2-068Vendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan