CVE-2025-66451
mediumpriority · track · 26EPSS 0.003 · 27 %ileEUUSEPSS · scored 2026-10-27
LibreChat is a ChatGPT clone with additional features. In versions 0.8.0 and below, when creating prompts, JSON requests are sent to define and modify the prompts via PATCH endpoint for prompt groups (/api/prompts/groups/:groupId). However, the request bodies are not sufficiently validated for proper input, enabling users to modify prompts in a way that was not intended as part of the front end system. The patchPromptGroup function passes req.body directly to updatePromptGroup() without filtering sensitive fields. This issue is fixed in version 0.8.1.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 1.3–6.5
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (2)
Products and version ranges known to be affected.
also known as (2)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (7)
External citations — patches, advisories, analysis.
- https://github.com/danny-avila/LibreChat/commit/01413eea3d3c1454d32ca9704fa9640407839737cnnvd
- https://github.com/danny-avila/LibreChat/releasesPatchcnnvd
- https://github.com/danny-avila/LibreChat/security/advisories/GHSA-vpqq-5qr4-655hcnnvd
- https://github.com/danny-avila/LibreChat/commit/01413eea3d3c1454d32ca9704fa9640407839737enisa_euvd
- https://github.com/danny-avila/LibreChat/security/advisories/GHSA-vpqq-5qr4-655henisa_euvd
- https://github.com/danny-avila/LibreChat/commit/01413eea3d3c1454d32ca9704fa9640407839737Patchnvd
- https://github.com/danny-avila/LibreChat/security/advisories/GHSA-vpqq-5qr4-655hExploitVendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan