CVE-2025-58068
criticalpriority · track · 36EPSS 0.004 · 34 %ileDEEURUUSEPSS · scored 2026-10-27
Eventlet is a concurrent networking library for Python. Prior to version 0.40.3, the Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections. This vulnerability could enable attackers to, bypass front-end security controls, launch targeted attacks against active site users, and poison web caches. This problem has been patched in Eventlet 0.40.3 by dropping trailers which is a breaking change if a backend behind eventlet.wsgi proxy requires trailers. A workaround involves not using eventlet.wsgi facing untrusted clients.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–critical · 1.7–9.1
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (23)
Products and version ranges known to be affected.
advisories (3)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2026-0408Red Hat OpenStack Services auf OpenShift (python-eventlet, keystone): Mehrere SchwachstellenDeutsch2026-02-12csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Red Hat OpenStack Services auf OpenShift ausnutzen, um Sicherheitsvorkehrungen zu umgehen oder Berechtigungen zu erweitern.
- GHSA-hw6f-rjfj-j7j7Eventlet affected by HTTP request smuggling in unparsed trailers2025-08-29ghsa · osvUS
### Impact The Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections. This vulnerability could enable attackers to: - Bypass front-end security controls - Launch targeted attacks against active site users - Poison web caches ### Patches Problem has been patched in eventlet 0.40.3. The patch just drops trailers. If a backend behind eventlet.wsgi proxy requires trailers, then this patch BREAKS your setup. ### Workarounds Do not use eventlet.wsgi facing untrusted clients. ### References - Patch https://github.com/eventlet/eventlet/pull/1062 - This issue is similar to https://github.com/advisories/GHSA-9548-qrrj-x5pj
- PYSEC-2026-1350Eventlet affected by HTTP request smuggling in unparsed trailers2026-07-07vendor · osvUS
### Impact The Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections. This vulnerability could enable attackers to: - Bypass front-end security controls - Launch targeted attacks against active site users - Poison web caches ### Patches Problem has been patched in eventlet 0.40.3. The patch just drops trailers. If a backend behind eventlet.wsgi proxy requires trailers, then this patch BREAKS your setup. ### Workarounds Do not use eventlet.wsgi facing untrusted clients. ### References - Patch https://github.com/eventlet/eventlet/pull/1062 - This issue is similar to https://github.com/advisories/GHSA-9548-qrrj-x5pj
also known as (7)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (13)
External citations — patches, advisories, analysis.
- https://github.com/eventlet/eventlet/commit/0bfebd1117d392559e25b4bfbfcc941754de88fbcnnvd
- https://github.com/eventlet/eventlet/pull/1062cnnvd
- https://github.com/eventlet/eventlet/security/advisories/GHSA-hw6f-rjfj-j7j7cnnvd
- https://github.com/eventlet/eventlet/tagsPatchcnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2025-58068cnnvd
- https://vigilance.fr/vulnerability/Eventlet-ingress-filtrering-bypass-via-WSGI-Parser-Request-Smuggling-48107cnnvd
- https://github.com/eventlet/eventlet/commit/0bfebd1117d392559e25b4bfbfcc941754de88fbenisa_euvd
- https://github.com/eventlet/eventlet/pull/1062enisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan