CVE-2025-55193

mediumpriority · track · 0EPSS 0.006 · 48 %ileDEEUUS
grimoire priorityP3 · Track
Exploitable?
—
no known exploitation
Likely / severe?
0.59% (48th) EPSS
CVSS 4.3 · medium
Is it mine?
16 products
Check your exposure
Who says so?
5 sources
cnnvd · enisa_euvd · cert_bund · osv

EPSS · scored 2026-10-27

Active Record connects classes to relational database tables. Prior to versions 7.1.5.2, 7.2.2.2, and 8.0.2.1, the ID passed to find or similar methods may be logged without escaping. If this is directly to the terminal it may include unescaped ANSI sequences. This issue has been patched in versions 7.1.5.2, 7.2.2.2, and 8.0.2.1.

01

remediations

Vendor fix, mitigation, or workaround guidance, as published by each source.

A vendor fix is available.

  • Fixedhawk2-0:2.7.0+git.1742310530.bfcd0e2c-160000.3.1.ppc64le as component of SUSE Linux Enterprise High Availability Extension 16.0suse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedhawk2-0:2.7.0+git.1742310530.bfcd0e2c-160000.3.1.s390x as component of SUSE Linux Enterprise High Availability Extension 16.0suse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedhawk2-0:2.7.0+git.1742310530.bfcd0e2c-160000.3.1.x86_64 as component of SUSE Linux Enterprise High Availability Extension 16.0suse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedhawk2-0:2.7.0+git.1742310530.bfcd0e2c-160000.3.1.ppc64le as component of SUSE Linux Enterprise Server for SAP applications 16.0suse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedhawk2-0:2.7.0+git.1742310530.bfcd0e2c-160000.3.1.x86_64 as component of SUSE Linux Enterprise Server for SAP applications 16.0suse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedruby4.0-rubygem-activerecord-8.0-0:8.0.3-1.3.aarch64 as component of openSUSE Tumbleweedsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedruby4.0-rubygem-activerecord-8.0-0:8.0.3-1.3.ppc64le as component of openSUSE Tumbleweedsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedruby4.0-rubygem-activerecord-8.0-0:8.0.3-1.3.s390x as component of openSUSE Tumbleweedsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedruby4.0-rubygem-activerecord-8.0-0:8.0.3-1.3.x86_64 as component of openSUSE Tumbleweedsuse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedhawk2-0:2.7.0+git.1742310530.bfcd0e2c-160000.3.1.aarch64 as component of openSUSE Leap 16.0suse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedhawk2-0:2.7.0+git.1742310530.bfcd0e2c-160000.3.1.ppc64le as component of openSUSE Leap 16.0suse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedhawk2-0:2.7.0+git.1742310530.bfcd0e2c-160000.3.1.s390x as component of openSUSE Leap 16.0suse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

  • Fixedhawk2-0:2.7.0+git.1742310530.bfcd0e2c-160000.3.1.x86_64 as component of openSUSE Leap 16.0suse_csaf

    To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".

02

cvss

Technical severity, 0–10. One row per scoring source.

4.3
010

base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 2.7–4.3

v3.14.3mediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:Nsecondary · SUSE Product Security
v4.02.7lowCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N/E:Usecondary · ENISA EU
v4.02.7lowCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:Xsecondary · security-advisories@github.com
v4.02.7lowCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:Xsecondary · CVSS-BT (t0sche)
03

ssvc

A stakeholder decision — act, attend, or track — from exploitation and impact.

Exploitation: none · Automatable: yes · Technical Impact: partialcoordinatorcisa_ssvcUS
04

weaknesses

The CWE weakness classes this flaw belongs to.

05

affected products (16)

Products and version ranges known to be affected.

06

advisories (6)

Vendor and ecosystem advisories describing this.

  • SUSE-SU-2026:20091-1Security update for hawk22026-01-13csaf · suse_csafDE

    Security update for hawk2

  • SUSE-SU-2026:20093-1Security update for hawk22026-01-13csaf · suse_csafDE

    Security update for hawk2

  • WID-SEC-W-2025-1822Ruby on Rails: Mehrere SchwachstellenDeutsch2025-08-13csaf · cert_bundDE

    Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Ruby on Rails ausnutzen, um beliebigen Programmcode auszuführen und Daten zu manipulieren.

  • openSUSE-SU-2026:10343-1ruby4.0-rubygem-activerecord-8.0-8.0.3-1.3 on GA media2026-03-13csaf · suse_csafDE

    ruby4.0-rubygem-activerecord-8.0-8.0.3-1.3 on GA media

  • openSUSE-SU-2026:20025-1Security update for hawk22026-01-13csaf · suse_csafDE

    Security update for hawk2

  • GHSA-76r7-hhxj-r776Active Record logging vulnerable to ANSI escape injection2025-08-13ghsa · osvUS

    This vulnerability has been assigned the CVE identifier CVE-2025-55193 ### Impact The ID passed to `find` or similar methods may be logged without escaping. If this is directly to the terminal it may include unescaped ANSI sequences. ### Releases The fixed releases are available at the normal locations. ### Credits Thanks to [lio346](https://hackerone.com/lio346) from Unit 515 of OPSWAT for reporting this vulnerability

07

also known as (3)

Other names and identifiers for this entity.

08

sources

Which sources assert this record, and when.

09

references (14)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan