CVE-2025-53689
highpriority · track · 0EPSS 0.005 · 45 %ileDEEUNLUSEPSS · scored 2026-10-22
Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (58)
Products and version ranges known to be affected.
advisories (4)
Vendor and ecosystem advisories describing this.
- NCSC-2026-0034Kwetsbaarheden verholpen in Atlassian productenNL2026-01-22csaf · ncsc_nlNL
Atlassian heeft kwetsbaarheden verholpen in verschillende producten, welke gebruik maken van Oracle middle-ware producten zoals de Oracle Utilities Application Framework, WebLogic Server, Data Integrator en Business Intelligence Enterprise Edition.
- WID-SEC-W-2025-1547Apache Jackrabbit Oak: Schwachstelle ermöglicht Offenlegung von InformationenDeutsch2025-07-14csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann eine Schwachstelle in Apache Jackrabbit Oak ausnutzen, um auf sensible Dateien oder Dienste zuzugreifen und möglicherweise andere nicht spezifizierte Angriffe durchzuführen.
- WID-SEC-W-2026-0177Atlassian Bamboo, Bitbucket, Confluence und Jira: Mehrere SchwachstellenDeutsch2026-01-20csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Atlassian Bamboo, Atlassian Bitbucket, Atlassian Confluence und Atlassian Jira ausnutzen, um beliebigen Programmcode auszuführen, um Sicherheitsvorkehrungen zu umgehen, um einen Denial of Service Angriff durchzuführen, und um einen Cross-Site Scripting Angriff durchzuführen.
- GHSA-44c3-38h8-9fh9Apache Jackrabbit vulnerable to blind XXE attack due to insecure document build2025-07-14ghsa · osvUS
Blind XXE vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (6)
External citations — patches, advisories, analysis.
- https://access.redhat.com/security/cve/cve-2025-53689cnnvd
- https://jackrabbit.apache.org/jcr/index.htmlPatchcnnvd
- https://lists.apache.org/thread/5pf9n76ny13pzzk765og2h3gxdxw7p24cnnvd
- https://lists.apache.org/thread/5pf9n76ny13pzzk765og2h3gxdxw7p24enisa_euvd
- http://www.openwall.com/lists/oss-security/2025/07/14/1nvd
- https://lists.apache.org/thread/5pf9n76ny13pzzk765og2h3gxdxw7p24Vendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan