CVE-2025-49812
highpriority · track · 10EPSS 0.006 · 49 %ileexploit · PoCDEEURUUSEPSS · scored 2026-10-24
In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack allows a man-in-the-middle attacker to hijack an HTTP session via a TLS upgrade. Only configurations using "SSLEngine optional" to enable TLS upgrades are affected. Users are recommended to upgrade to version 2.4.64, which removes support for TLS upgrade.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
exploits (1)
Public proof-of-concept and weaponised exploit code.
- kimdongjun22/cve-2025-49812-ctfkimdongjun22/cve-2025-49812-ctfPoC · poc_in_github
affected products (128)
Products and version ranges known to be affected.
- IBM Power Hardware Management Console V10all versionscert_bundDEcpe:/a:ibm:hardware_management_console:v10
- IBM Power Hardware Management Console V10.3.1050.0-V10.3.1064.1all versionscert_bundDEcpe:/a:ibm:hardware_management_console:v10.3.1050.0_-_v10.3.1064.1
- IBM Power Hardware Management Console V11.1.1110.0-V11.1.1112.1all versionscert_bundDEcpe:/a:ibm:hardware_management_console:v11.1.1110.0_-_v11.1.1112.1
advisories (3)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2025-1529Apache HTTP Server: Mehrere SchwachstellenDeutsch2025-07-10csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Apache HTTP Server ausnutzen, um einen Denial of Service Angriff durchzuführen, um Sicherheitsvorkehrungen zu umgehen, um Informationen offenzulegen, und um Dateien zu manipulieren.
- WID-SEC-W-2025-1850Xerox FreeFlow Print Server: Mehrere Schwachstellen ermöglichen nicht spezifizierten AngriffDeutsch2025-08-14csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Xerox FreeFlow Print Server ausnutzen, um einen nicht näher spezifizierten Angriff durchzuführen.
- BIT-apache-2025-49812Apache HTTP Server: mod_ssl TLS upgrade attack2025-07-16vendor · osvUS
In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack allows a man-in-the-middle attacker to hijack an HTTP session via a TLS upgrade. Only configurations using "SSLEngine optional" to enable TLS upgrades are affected. Users are recommended to upgrade to version 2.4.64, which removes support for TLS upgrade.
also known as (4)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (11)
External citations — patches, advisories, analysis.
- https://cnnvd
- https://access.redhat.com/security/cve/cve-2025-49812cnnvd
- https://httpd.apache.org/download.cgiPatchcnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2025-49812cnnvd
- https://vigilance.fr/vulnerability/Apache-cnnvd
- https://httpd.apache.org/security/vulnerabilities_24.htmlenisa_euvd
- http://www.openwall.com/lists/oss-security/2025/07/09/3nvd
- http://www.openwall.com/lists/oss-security/2025/07/10/2nvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan