CVE-2025-48912
mediumpriority · track · 26EPSS 0.008 · 56 %ileDEEURUUSEPSS · scored 2026-10-27
An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 4.9–7.1
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (7)
Products and version ranges known to be affected.
advisories (4)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2025-1168Apache Superset: Schwachstelle ermöglicht SQL InjectionDeutsch2025-05-29csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann eine Schwachstelle in Apache Superset ausnutzen, um eine SQL Injection durchzuführen, und somit Daten zu manipulieren.
- GHSA-8w7f-8pr9-xgwjApache Superset: Improper authorization bypass on row level security via SQL Injection2025-05-30ghsa · osvUS
An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.
- BIT-superset-2025-48912Apache Superset: Improper authorization bypass on row level security via SQL Injection2025-06-03vendor · osvUS
An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.
- PYSEC-2026-1164Apache Superset: Improper authorization bypass on row level security via SQL Injection2026-07-07vendor · osvUS
An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.
also known as (8)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (7)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2025/05/30/3cnnvd
- https://lists.apache.org/thread/ms2t2oq218hb7l628trsogo4fj7h1135cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2025-48912cnnvd
- https://superset.apache.org/Patchcnnvd
- https://lists.apache.org/thread/ms2t2oq218hb7l628trsogo4fj7h1135enisa_euvd
- http://www.openwall.com/lists/oss-security/2025/05/30/3Mailing Listnvd
- https://lists.apache.org/thread/ms2t2oq218hb7l628trsogo4fj7h1135Mailing Listnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan