CVE-2025-31650

highpriority · attend · 61EPSS 0.613 · 99 %ileexploit · PoCDEEURUUS
grimoire priorityP1 · Urgent
Exploitable?
Public exploit
7 exploits · PoC
Likely / severe?
61.3% (99th) EPSS
CVSS 7.5 · high
Is it mine?
67 products
Check your exposure
Who says so?
6 sources
cnnvd · enisa_euvd · fstec_bdu · osv

EPSS · scored 2026-10-22

Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service. This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.

01

remediations

Vendor fix, mitigation, or workaround guidance, as published by each source.

A vendor fix is available.

  • FixedPIT User Authentication Servicepilz_psirt

    Please visit the Pilz website (https://www.pilz.com/en-INT/search) and install the new version 'Software PIT User Auth. Service 1.4.1' on to your device.

  • FixedPIT User Authentication Service 1.4.0pilz_psirt

    Please visit the Pilz website (https://www.pilz.com/en-INT/search) and install the new version 'Software PIT User Auth. Service 1.4.1' on to your device.

  • MitigationPIT User Authentication Servicepilz_psirt

    Limit network access to the PITreader and PIT User Authentication Service by using a firewall, a host-based firewall or similar measures.

  • MitigationPIT User Authentication Service 1.4.0pilz_psirt

    Limit network access to the PITreader and PIT User Authentication Service by using a firewall, a host-based firewall or similar measures.

02

cvss

Technical severity, 0–10. One row per scoring source.

7.5
010

base score 0–10 · higher = more severe · hover a vector to decode

v3.17.5highCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:Hprimary · NVD / NIST USexploitability 3.9 · impact 3.6
v3.17.5highAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:Hsecondary · FSTEC (BDU) RU
v3.17.5highCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:Hsecondary · ENISA EU
v3.17.5highCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:Hsecondaryexploitability 3.9 · impact 3.6
v3.17.5highCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:Hsecondary · Pilz PSIRT DE
v3.17.5highCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:Hsecondary · CVSS-BT (t0sche)
03

ssvc

A stakeholder decision — act, attend, or track — from exploitation and impact.

Exploitation: none · Automatable: yes · Technical Impact: partialcoordinatorcisa_ssvcUS
04

weaknesses

The CWE weakness classes this flaw belongs to.

05

exploits (7)

Public proof-of-concept and weaponised exploit code.

06

affected products (67)

Products and version ranges known to be affected.

07

advisories (9)

Vendor and ecosystem advisories describing this.

  • PPSA-2026-001Pilz: Multiple Vulnerabilities affecting the PIT User Authentication Service2026-02-02csaf · pilz_psirtDE

    **PIT User Authentication Service is part of the operating mode selection and access permission system PITmode.** The PIT User Authentication Service is affected by multiple vulnerabilities in included third-party components.

  • WID-SEC-W-2025-0895Apache Tomcat: Mehrere SchwachstellenDeutsch2025-04-28csaf · cert_bundDE

    Ein Angreifer kann mehrere Schwachstellen in Apache Tomcat ausnutzen, um einen Denial of Service Angriff durchzuführen, oder Sicherheitsvorkehrungen zu umgehen.

  • WID-SEC-W-2025-1343Atlassian Bitbucket: Mehrere Schwachstellen ermöglichen Denial of ServiceDeutsch2025-06-17csaf · cert_bundDE

    Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Atlassian Bitbucket ausnutzen, um einen Denial of Service Angriff durchzuführen.

  • WID-SEC-W-2025-1365IBM QRadar SIEM: Mehrere SchwachstellenDeutsch2025-06-19csaf · cert_bundDE

    Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in IBM QRadar SIEM ausnutzen, um Informationen offenzulegen, einen Denial of Service Zustand herbeizuführen, um beliebige Befehle auszuführen und um nicht näher spezifizierte Auswirkungen zu verursachen.

  • WID-SEC-W-2025-1439Dell Secure Connect Gateway: Mehrere Schwachstellen ermöglichen nicht spezifizierten AngriffDeutsch2025-06-30csaf · cert_bundDE

    Ein Angreifer kann mehrere Schwachstellen in Dell Secure Connect Gateway ausnutzen, um einen nicht näher spezifizierten Angriff durchzuführen.

  • WID-SEC-W-2025-1850Xerox FreeFlow Print Server: Mehrere Schwachstellen ermöglichen nicht spezifizierten AngriffDeutsch2025-08-14csaf · cert_bundDE

    Ein Angreifer kann mehrere Schwachstellen in Xerox FreeFlow Print Server ausnutzen, um einen nicht näher spezifizierten Angriff durchzuführen.

  • WID-SEC-W-2026-0351Dell NetWorker (Third Party Components): Mehrere SchwachstellenDeutsch2026-02-09csaf · cert_bundDE

    Ein Angreifer kann mehrere Schwachstellen in Dell NetWorker ausnutzen, um Angriffe zu starten, die die Integrität, Vertraulichkeit und Verfügbarkeit von Systemen beeinträchtigen.

  • GHSA-3p2h-wqq4-wf4hApache Tomcat Denial of Service via invalid HTTP priority header2025-04-28ghsa · osvUS

    Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service. This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.

  • BIT-tomcat-2025-31650Apache Tomcat: DoS via malformed HTTP/2 PRIORITY_UPDATE frame2025-04-30vendor · osvUS

    Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service. This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.

08

also known as (7)

Other names and identifiers for this entity.

09

sources

Which sources assert this record, and when.

10

references (11)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan