CVE-2025-29927
criticalpriority · attend · 45OT risk · highEPSS 0.992 · 100 %ileexploit · functionalDEEUNLRUUSEPSS · scored 2026-10-27
Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
exploits (129)
Public proof-of-concept and weaponised exploit code.
- EDB-52124Next.js Middleware 15.2.2 - Authorization BypassPoC · exploit_db
- 0xPThree/next.js_cve-2025-299270xPThree/next.js_cve-2025-29927PoC · poc_in_github
- 0xPb1/Next.js-CVE-2025-299270xPb1/Next.js-CVE-2025-29927PoC · poc_in_github
- 0xb1lal/CVE-2025-29927Next.js CVE-2025-29927 güvenlik açığı hakkındaPoC · poc_in_github
affected products (31)
Products and version ranges known to be affected.
advisories (3)
Vendor and ecosystem advisories describing this.
- NCSC-2025-0096Kwetsbaarheid verholpen in Next.jsNL2025-03-25csaf · ncsc_nlNL
Vercel heeft een kwetsbaarheid verholpen in Next.js (Specifiek voor versies 14.2.25 en 15.2.3)
- WID-SEC-W-2025-0627Vercel Next.js: Schwachstelle ermöglicht Umgehen von SicherheitsvorkehrungenDeutsch2025-03-24csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann eine Schwachstelle in Vercel Next.js ausnutzen, um Sicherheitsvorkehrungen zu umgehen.
- GHSA-f82v-jwr5-mffwAuthorization Bypass in Next.js Middleware2025-03-21ghsa · osvUS
# Impact It is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. # Patches * For Next.js 15.x, this issue is fixed in `15.2.3` * For Next.js 14.x, this issue is fixed in `14.2.25` * For Next.js 13.x, this issue is fixed in 13.5.9 * For Next.js 12.x, this issue is fixed in 12.3.5 * For Next.js 11.x, consult the below workaround. _Note: Next.js deployments hosted on Vercel are automatically protected against this vulnerability._ # Workaround If patching to a safe version is infeasible, we recommend that you prevent external user requests which contain the `x-middleware-subrequest` header from reaching your Next.js application. ## Credits - Allam Rachid (zhero;) - Allam Yasser (inzo_)
also known as (4)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (23)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2025/03/23/3cnnvd
- http://www.openwall.com/lists/oss-security/2025/03/23/4cnnvd
- https://access.redhat.com/security/cve/cve-2025-29927cnnvd
- https://github.com/vercel/next.js/commit/52a078da3884efe6501613c7834a3d02a91676d2cnnvd
- https://github.com/vercel/next.js/commit/5fd3ae8f8542677c6294f32d18022731eab6fe48cnnvd
- https://github.com/vercel/next.js/releases/tag/v12.3.5cnnvd
- https://github.com/vercel/next.js/releases/tag/v13.5.9cnnvd
- https://github.com/vercel/next.js/security/advisories/GHSA-f82v-jwr5-mffwcnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan