CVE-2025-24814
mediumpriority · track · 22EPSS 0.012 · 67 %ileDEEURUUSEPSS · scored 2026-10-22
Core creation allows users to replace "trusted" configset files with arbitrary configuration Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem. These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin. This issue affects all Apache Solr versions up through Solr 9.7. Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService"). Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (17)
Products and version ranges known to be affected.
- IBM Operational Decision Manager 8.11.0.1all versionscert_bundDEcpe:/a:ibm:operational_decision_manager:8.11.0.1
- IBM Operational Decision Manager 8.11.1.0all versionscert_bundDEcpe:/a:ibm:operational_decision_manager:8.11.1.0
- IBM Operational Decision Manager 8.12.0.1all versionscert_bundDEcpe:/a:ibm:operational_decision_manager:8.12.0.1
- IBM Operational Decision Manager 9.0.0.1all versionscert_bundDEcpe:/a:ibm:operational_decision_manager:9.0.0.1
- IBM Operational Decision Manager 9.5.0.0all versionscert_bundDEcpe:/a:ibm:operational_decision_manager:9.5.0.0
- IBM Operational Decision Manager 9.5.0.1all versionscert_bundDEcpe:/a:ibm:operational_decision_manager:9.5.0.1
advisories (4)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2025-0197Apache Solr: Mehrere SchwachstellenDeutsch2025-01-26csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in Apache Solr ausnutzen, um Dateien zu manipulieren oder seine Rechte zu erweitern.
- WID-SEC-W-2025-1560Oracle Communications Applications: Mehrere SchwachstellenDeutsch2025-07-15csaf · cert_bundDE
Ein entfernter, anonymer oder authentisierter Angreifer kann mehrere Schwachstellen in Oracle Communications Applications ausnutzen, um die Vertraulichkeit, Integrität und Verfügbarkeit zu gefährden.
- GHSA-68r2-fwcg-qpm8Apache Solr vulnerable to Execution with Unnecessary Privileges2025-01-27ghsa · osvUS
Core creation allows users to replace "trusted" configset files with arbitrary configuration Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem. These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin. This issue affects all Apache Solr versions up through Solr 9.7. Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService"). Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default.
- BIT-solr-2025-24814Apache Solr: Core-creation with "trusted" configset can use arbitrary untrusted files2025-01-29vendor · osvUS
Core creation allows users to replace "trusted" configset files with arbitrary configuration Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem. These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin. This issue affects all Apache Solr versions up through Solr 9.7. Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService"). Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default.
also known as (6)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (7)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2025/01/26/1cnnvd
- https://lists.apache.org/thread/gl291pn8x9f9n52ys5l0pc0b6qtf0qw1cnnvd
- https://www.oracle.com/security-alerts/cpujul2025.htmlcnnvd
- https://lists.apache.org/thread/gl291pn8x9f9n52ys5l0pc0b6qtf0qw1enisa_euvd
- http://www.openwall.com/lists/oss-security/2025/01/26/1Mailing ListThird Party Advisorynvd
- https://lists.apache.org/thread/gl291pn8x9f9n52ys5l0pc0b6qtf0qw1Mailing ListVendor Advisorynvd
- https://security.netapp.com/advisory/ntap-20250214-0002/Third Party Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan