CVE-2025-23391
criticalpriority · track · 0EPSS 0.005 · 40 %ileDEEURUUSEPSS · scored 2026-10-27
A Incorrect Privilege Assignment vulnerability in SUSE rancher allows a Restricted Administrator to change the password of Administrators and take over their accounts. This issue affects rancher: from 2.8.0 before 2.8.14, from 2.9.0 before 2.9.8, from 2.10.0 before 2.10.4.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · high–critical · 8.3–9.1
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (19)
Products and version ranges known to be affected.
advisories (3)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2025-0665Rancher: Schwachstelle ermöglicht ermöglicht PrivilegieneskalationDeutsch2025-03-31csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann eine Schwachstelle in Rancher ausnutzen, um seine Privilegien zu erhöhen.
- GHSA-8p83-cpfg-fj3gRancher: Restricted Administrator can change Administrator's passwords2025-04-01ghsa · osvUS
### Impact A vulnerability has been identified within Rancher where a Restricted Administrator can change the password of Administrators and take over their accounts. A Restricted Administrator should be not allowed to change the password of more privileged users unless it contains the Manage Users permissions. Rancher deployments where the Restricted Administrator role is not being used are not affected by this CVE. Please consult the associated [MITRE ATT&CK - Technique - Abuse Elevation Control Mechanism](https://attack.mitre.org/techniques/T1548/) for further information about this category of attack. ### Patches The fix introduces a few changes: 1. If the user has a manage-users verb, the user is allowed to edit/delete users. That way the Manage Users built in role will still be able to edit ALL users. 2. If the user doesn't have manage-users, just edit or delete, then there is a check to ensure that the User being edited only has rules equal to or less than the editor. Patched versions include releases `v2.8.14`, `v2.9.8`, `v2.10.4` and `v2.11.0` ### Workarounds Users are recommended to upgrade, as soon as possible, to a version of Rancher Manager that contains the fix. If users can't upgrade, the following are recommended: 1. Limit access to Rancher Restricted Admin only to trusted users. 2. Downgrade Restricted Administrators to custom roles with limited permissions. ### Credits This issue was identified and reported by Xavier Duthil from OVHcloud. ### References If you have any questions or comments about this advisory: - Reach out to the [SUSE Rancher Security team](https://github.com/rancher/rancher/security/policy) for security related inquiries. - Open an issue in the [Rancher](https://github.com/rancher/rancher/issues/new/choose) repository. - Verify with our [support matrix](https://www.suse.com/suse-rancher/support-matrix/all-supported-versions/) and [product support lifecycle](https://www.suse.com/lifecycle/).
- GO-2025-3586Rancher: Restricted Administrator can change Administrator's passwords in github.com/rancher/rancher2025-04-02vendor · osvUS
Rancher: Restricted Administrator can change Administrator's passwords in github.com/rancher/rancher. NOTE: The source advisory for this report contains additional versions that could not be automatically mapped to standard Go module versions. (If this is causing false-positive reports from vulnerability scanners, please suggest an edit to the report.) The additional affected modules and versions are: github.com/rancher/rancher from v2.8.0 before v2.8.14, from v2.9.0 before v2.9.8, from v2.10.0 before v2.10.4.
also known as (6)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (8)
External citations — patches, advisories, analysis.
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2025-23391cnnvd
- https://github.com/rancher/rancher/releasesPatchcnnvd
- https://github.com/rancher/rancher/security/advisories/GHSA-8p83-cpfg-fj3gcnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2025-23391cnnvd
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2025-23391enisa_euvd
- https://github.com/rancher/rancher/security/advisories/GHSA-8p83-cpfg-fj3genisa_euvd
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2025-23391nvd
- https://github.com/rancher/rancher/security/advisories/GHSA-8p83-cpfg-fj3gnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan