CVE-2025-23388
highpriority · track · 0EPSS 0.006 · 49 %ileDEEUUSEPSS · scored 2026-10-27
A Stack-based Buffer Overflow vulnerability in SUSE rancher allows for denial of service.This issue affects rancher: from 2.8.0 before 2.8.13, from 2.9.0 before 2.9.7, from 2.10.0 before 2.10.3.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (13)
Products and version ranges known to be affected.
advisories (3)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2025-0457Rancher: Mehrere SchwachstellenDeutsch2025-02-27csaf · cert_bundDE
Ein entfernter, anonymer oder authentisierter Angreifer kann mehrere Schwachstellen in Rancher ausnutzen, um Dateien zu manipulieren, administrative Rechte zu erlangen und einen Denial-of-Service-Zustand auszulösen.
- GHSA-xr9q-h9c7-xw8qRancher allows an unauthenticated stack overflow in /v3-public/authproviders API2025-02-27ghsa · osvUS
### Impact An unauthenticated stack overflow crash, leading to a denial of service (DoS), was identified in Rancher’s `/v3-public/authproviders` public API endpoint. A malicious user could submit data to the API which would cause the Rancher server to crash, but no malicious or incorrect data would actually be written in the API. The downstream clusters, i.e., the clusters managed by Rancher, are not affected by this issue. This vulnerability affects those using external authentication providers as well as Rancher’s local authentication. ### Patches The patch includes the removal of unnecessary HTTP methods of the specific API. Patched versions include releases `v2.8.13`, `v2.9.7` and `v2.10.3`. ### Workarounds There are no workarounds for this issue. Users are recommended to upgrade, as soon as possible, to a version of Rancher Manager that contains the fix. ### References If you have any questions or comments about this advisory: - Reach out to the [SUSE Rancher Security team](https://github.com/rancher/rancher/security/policy) for security related inquiries. - Open an issue in the [Rancher](https://github.com/rancher/rancher/issues/new/choose) repository. - Verify with our [support matrix](https://www.suse.com/suse-rancher/support-matrix/all-supported-versions/) and [product support lifecycle](https://www.suse.com/lifecycle/).
- GO-2025-3491Rancher allows an unauthenticated stack overflow in /v3-public/authproviders API in github.com/rancher/rancher2025-03-03vendor · osvUS
Rancher allows an unauthenticated stack overflow in /v3-public/authproviders API in github.com/rancher/rancher. NOTE: The source advisory for this report contains additional versions that could not be automatically mapped to standard Go module versions. (If this is causing false-positive reports from vulnerability scanners, please suggest an edit to the report.) The additional affected modules and versions are: github.com/rancher/rancher from v2.8.0 before v2.8.13, from v2.9.0 before v2.9.7, from v2.10.0 before v2.10.3.
also known as (5)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (8)
External citations — patches, advisories, analysis.
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2025-23388cnnvd
- https://github.com/rancher/rancher/releasesPatchcnnvd
- https://github.com/rancher/rancher/security/advisories/GHSA-xr9q-h9c7-xw8qcnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2025-23388cnnvd
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2025-23388enisa_euvd
- https://github.com/rancher/rancher/security/advisories/GHSA-xr9q-h9c7-xw8qenisa_euvd
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2025-23388nvd
- https://github.com/rancher/rancher/security/advisories/GHSA-xr9q-h9c7-xw8qnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan