CVE-2025-21610
mediumpriority · track · 0EPSS 0.004 · 36 %ileEUUSEPSS · scored 2026-10-28
Trix is a what-you-see-is-what-you-get rich text editor for everyday writing. Versions prior to 2.1.12 are vulnerable to cross-site scripting when pasting malicious code in the link field. An attacker could trick the user to copy&paste a malicious `javascript:` URL as a link that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.12 or later to receive a patch. In addition to upgrading, affected users can disallow browsers that don't support a Content Security Policy (CSP) as a workaround for this and other cross-site scripting vulnerabilities. Set CSP policies such as script-src 'self' to ensure that only scripts hosted on the same origin are executed, and explicitly prohibit inline scripts using script-src-elem.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (2)
Products and version ranges known to be affected.
advisories (1)
Vendor and ecosystem advisories describing this.
- GHSA-j386-3444-qgwgTrix allows Cross-site Scripting via `javascript:` url in a link2025-01-03ghsa · osvUS
The Trix editor, versions prior to 2.1.11, is vulnerable to XSS when pasting malicious code in the link field. ### Impact An attacker could trick the user to copy&paste a malicious `javascript:` URL as a link that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. See https://gist.github.com/th4s1s/3921fd9c3e324ad9a3e0d846166e3eb8 ### Patches Update Recommendation: Users should upgrade to Trix editor version 2.1.12 or later. ### Workarounds This is not really a workaround but something that should be considered in addition to upgrading to the patched version. If affected users can disallow browsers that don't support a Content Security Policy, then this would be an effective workaround for this and all XSS vulnerabilities. Set CSP policies such as script-src 'self' to ensure that only scripts hosted on the same origin are executed, and explicitly prohibit inline scripts using script-src-elem. ### References https://gist.github.com/th4s1s/3921fd9c3e324ad9a3e0d846166e3eb8 ### Credits This vulnerability was reported by Hackerone researcher https://hackerone.com/lio346?type=user
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (13)
External citations — patches, advisories, analysis.
- https://gist.github.com/th4s1s/3921fd9c3e324ad9a3e0d846166e3eb8cnnvd
- https://github.com/basecamp/trix/commit/180c8d337f18e1569cea6ef29b4d03ffff5b5faacnnvd
- https://github.com/basecamp/trix/commit/c4f0d6f80654603932af6685694f694e96593b93cnnvd
- https://github.com/basecamp/trix/releases/tag/v2.1.12Patchcnnvd
- https://github.com/basecamp/trix/security/advisories/GHSA-j386-3444-qgwgcnnvd
- https://gist.github.com/th4s1s/3921fd9c3e324ad9a3e0d846166e3eb8enisa_euvd
- https://github.com/basecamp/trix/commit/180c8d337f18e1569cea6ef29b4d03ffff5b5faaenisa_euvd
- https://github.com/basecamp/trix/commit/c4f0d6f80654603932af6685694f694e96593b93enisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan