CVE-2024-53977
highpriority · track · 31EPSS 0.002 · 4 %ileDEEUNLUSEPSS · scored 2026-10-22
A vulnerability has been identified in ModelSim (All versions < V2025.1), Questa (All versions < V2025.1). An example setup script contained in affected applications allows a specific executable file to be loaded from the current working directory. This could allow an authenticated local attacker to inject arbitrary code and escalate privileges in installations where administrators or processes with elevated privileges launch the script from a user-writable directory.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- FixedModelSimsiemens_psirt
Update to V2025.1 or later version
- FixedQuestasiemens_psirt
Update to V2025.1 or later version
- FixedModelSimcisa_csaf_ot
Update to V2025.1 or later version
- FixedQuestacisa_csaf_ot
Update to V2025.1 or later version
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–high · 2–7.8
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (22)
Products and version ranges known to be affected.
- apogee_pxc_series__bacnet_all versionsncsc_nlNLcpe:2.3:a:siemens:apogee_pxc_series__bacnet_:*:*:*:*:*:*:*:*
- apogee_pxc_series__p2_ethernet_all versionsncsc_nlNLcpe:2.3:a:siemens:apogee_pxc_series__p2_ethernet_:*:*:*:*:*:*:*:*
- opcenter_intelligenceall versionsncsc_nlNLcpe:2.3:a:siemens:opcenter_intelligence:2501:*:*:*:*:*:*:*
- siemens opcenter intelligenceall versionsncsc_nlNLcpe:2.3:a:siemens:opcenter_intelligence:*:*:*:*:*:*:*:*
advisories (3)
Vendor and ecosystem advisories describing this.
- NCSC-2025-0061Kwetsbaarheden verholpen in Siemens productenNL2025-02-14csaf · ncsc_nlNL
Siemens heeft kwetsbaarheden verholpen in diverse producten als APOGEE, Opcenter, RUGGEDCOM, SCALANCE, SIMATIC, SIPROTEC en Teamcenter.
- SSA-637914SSA-637914: Local Code Execution Vulnerability in Questa and ModelSim Before V2025.12025-02-11csaf · siemens_psirtDE
Questa and ModelSim (incl. OEM Editions) are affected by a vulnerability that could allow a local attacker to inject arbitrary code and escalate privileges. Siemens has released new versions for the affected products and recommends to update to the latest versions.
- ICSA-25-044-10Siemens Questa and ModelSim2025-02-11icsa · cisa_csaf_otUS
Questa and ModelSim (incl. OEM Editions) are affected by a vulnerability that could allow a local attacker to inject arbitrary code and escalate privileges. Siemens has released new versions for the affected products and recommends to update to the latest versions.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (3)
External citations — patches, advisories, analysis.
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan