CVE-2024-53949
mediumpriority · track · 26OT risk · elevatedEPSS 0.007 · 54 %ileDEEURUUSEPSS · scored 2026-10-27
Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API. issue affects Apache Superset: from 2.0.0 before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 4.9–7.6
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (7)
Products and version ranges known to be affected.
advisories (4)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2024-3641Apache Superset: Mehrere SchwachstellenDeutsch2024-12-09csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in Apache Superset ausnutzen, um sich erweiterte Rechte zu verschaffen, Daten zu manipulieren und Metadaten aus Analysedatenbanken offenzulegen.
- GHSA-35fc-9hrj-3585Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled2024-12-09ghsa · osvUS
Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API. issue affects Apache Superset: from 2.0.0 before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.
- BIT-superset-2024-53949Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled2025-02-05vendor · osvUS
Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API. issue affects Apache Superset: from 2.0.0 before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.
- PYSEC-2026-1156Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled2026-07-07vendor · osvUS
Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API. issue affects Apache Superset: from 2.0.0 before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.
also known as (8)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (5)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2024/12/09/4cnnvd
- https://lists.apache.org/thread/d3scbwmfpzbpm6npnzdw5y4owtqqyq8dcnnvd
- https://lists.apache.org/thread/d3scbwmfpzbpm6npnzdw5y4owtqqyq8denisa_euvd
- http://www.openwall.com/lists/oss-security/2024/12/09/4Mailing ListThird Party Advisorynvd
- https://lists.apache.org/thread/d3scbwmfpzbpm6npnzdw5y4owtqqyq8dMailing ListVendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan