CVE-2024-48057
mediumpriority · track · 0EPSS 0.002 · 14 %ileDEEUUSEPSS · scored 2026-10-27
localai <=2.20.1 is vulnerable to Cross Site Scripting (XSS). When calling the delete model API and passing inappropriate parameters, it can cause a one-time storage XSS, which will trigger the payload when a user accesses the homepage.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- Fixedgovulncheck-vulndb-0.0.20241112T145010-150000.1.17.1.noarch as component of SUSE Linux Enterprise Module for Package Hub 15 SP5suse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedgovulncheck-vulndb-0.0.20241112T145010-150000.1.17.1.noarch as component of SUSE Linux Enterprise Module for Package Hub 15 SP6suse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedgovulncheck-vulndb-0.0.20241112T145010-150000.1.17.1.noarch as component of openSUSE Leap 15.5suse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedgovulncheck-vulndb-0.0.20241112T145010-150000.1.17.1.noarch as component of openSUSE Leap 15.6suse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (4)
Products and version ranges known to be affected.
advisories (3)
Vendor and ecosystem advisories describing this.
- SUSE-SU-2024:4042-1Security update for govulncheck-vulndb2024-11-22csaf · suse_csafDE
Security update for govulncheck-vulndb
- GHSA-ghx4-cgxw-7h9pLocalAI Cross-site Scripting vulnerability2024-11-05ghsa · osvUS
localai <=2.20.1 is vulnerable to Cross Site Scripting (XSS). When calling the delete model API and passing inappropriate parameters, it can cause a one-time storage XSS, which will trigger the payload when a user accesses the homepage.
- GO-2024-3253LocalAI Cross-site Scripting vulnerability in github.com/mudler/LocalAI2024-11-06vendor · osvUS
LocalAI Cross-site Scripting vulnerability in github.com/mudler/LocalAI
also known as (5)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (6)
External citations — patches, advisories, analysis.
- https://github.com/mudler/localaiPatchcnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2024-48057cnnvd
- https://gist.github.com/AfterSnows/1bd7ee5a3a42dbb5f5ff67f7f9c8ccecenisa_euvd
- https://rumbling-slice-eb0.notion.site/LocalAI-deleted-model-with-storage-XSS-CSRF-vulnerability-in-mudler-localai-101e3cda9e8c80e0ac12fe418d5dd982?pvs=4enisa_euvd
- https://gist.github.com/AfterSnows/1bd7ee5a3a42dbb5f5ff67f7f9c8ccecThird Party Advisorynvd
- https://rumbling-slice-eb0.notion.site/LocalAI-deleted-model-with-storage-XSS-CSRF-vulnerability-in-mudler-localai-101e3cda9e8c80e0ac12fe418d5dd982?pvs=4ExploitThird Party Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan