CVE-2024-45217
highpriority · track · 0OT risk · elevatedEPSS 0.007 · 54 %ileDEEUNLUSEPSS · scored 2026-10-27
Insecure Default Initialization of Resource vulnerability in Apache Solr. New ConfigSets that are created via a Restore command, which copy a configSet from the backup and give it a new name, are created without setting the "trusted" metadata. ConfigSets that do not contain the flag are trusted implicitly if the metadata is missing, therefore this leads to "trusted" ConfigSets that may not have been created with an Authenticated request. "trusted" ConfigSets are able to load custom code into classloaders, therefore the flag is supposed to only be set when the request that uploads the ConfigSet is Authenticated & Authorized. This issue affects Apache Solr: from 6.6.0 before 8.11.4, from 9.0.0 before 9.7.0. This issue does not affect Solr instances that are secured via Authentication/Authorization. Users are primarily recommended to use Authentication and Authorization when running Solr. However, upgrading to version 9.7.0, or 8.11.4 will mitigate this issue otherwise.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (32)
Products and version ranges known to be affected.
- IBM Operational Decision Manager 8.11.0.1all versionscert_bundDEcpe:/a:ibm:operational_decision_manager:8.11.0.1
- IBM Operational Decision Manager 8.11.1.0all versionscert_bundDEcpe:/a:ibm:operational_decision_manager:8.11.1.0
- IBM Operational Decision Manager 8.12.0.1all versionscert_bundDEcpe:/a:ibm:operational_decision_manager:8.12.0.1
- IBM Operational Decision Manager 9.0.0.1all versionscert_bundDEcpe:/a:ibm:operational_decision_manager:9.0.0.1
- IBM Operational Decision Manager 9.5.0.0all versionscert_bundDEcpe:/a:ibm:operational_decision_manager:9.5.0.0
- IBM Operational Decision Manager 9.5.0.1all versionscert_bundDEcpe:/a:ibm:operational_decision_manager:9.5.0.1
- netweaver_java_application_serverall versionsncsc_nlNLcpe:2.3:a:sap:netweaver_java_application_server:7.5:*:*:*:*:*:*:*
advisories (5)
Vendor and ecosystem advisories describing this.
- NCSC-2025-0045Kwetsbaarheden verholpen in SAP productenNL2025-02-11csaf · ncsc_nlNL
SAP heeft kwetsbaarheden verholpen in onder andere SAP NetWeaver, BusinessObjects Business Intelligence platform, Enterprise Project Connection en Commerce.
- WID-SEC-W-2024-3186Apache Solr: Mehrere Schwachstellen ermöglichen Umgehen von SicherheitsvorkehrungenDeutsch2024-10-15csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Apache Solr ausnutzen, um Sicherheitsvorkehrungen zu umgehen.
- WID-SEC-W-2025-0307SAP Patchday Februar 2025: Mehrere SchwachstellenDeutsch2025-02-10csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in der SAP-Software ausnutzen, um erhöhte Berechtigungen zu erlangen, Sicherheitsmaßnahmen zu umgehen, Cross-Site-Scripting- und Spoofing-Angriffe durchzuführen, Daten zu manipulieren, vertrauliche Informationen preiszugeben und einen Denial-of-Service-Zustand zu verursachen.
- GHSA-h7w9-c5vx-x7j3Insecure Default Initialization of Resource vulnerability in Apache Solr2024-10-16ghsa · osvUS
New ConfigSets that are created via a Restore command, which copy a configSet from the backup and give it a new name, are created without setting the "trusted" metadata. ConfigSets that do not contain the flag are trusted implicitly if the metadata is missing, therefore this leads to "trusted" ConfigSets that may not have been created with an Authenticated request. "trusted" ConfigSets are able to load custom code into classloaders, therefore the flag is supposed to only be set when the request that uploads the ConfigSet is Authenticated & Authorized. This issue affects Apache Solr: from 6.6.0 before 8.11.4, from 9.0.0 before 9.7.0. This issue does not affect Solr instances that are secured via Authentication/Authorization. Users are primarily recommended to use Authentication and Authorization when running Solr. However, upgrading to version 9.7.0, or 8.11.4 will mitigate this issue otherwise.
- BIT-solr-2024-45217Apache Solr: ConfigSets created during a backup restore command are trusted implicitly2024-10-18vendor · osvUS
Insecure Default Initialization of Resource vulnerability in Apache Solr. New ConfigSets that are created via a Restore command, which copy a configSet from the backup and give it a new name, are created without setting the "trusted" metadata. ConfigSets that do not contain the flag are trusted implicitly if the metadata is missing, therefore this leads to "trusted" ConfigSets that may not have been created with an Authenticated request. "trusted" ConfigSets are able to load custom code into classloaders, therefore the flag is supposed to only be set when the request that uploads the ConfigSet is Authenticated & Authorized. This issue affects Apache Solr: from 6.6.0 before 8.11.4, from 9.0.0 before 9.7.0. This issue does not affect Solr instances that are secured via Authentication/Authorization. Users are primarily recommended to use Authentication and Authorization when running Solr. However, upgrading to version 9.7.0, or 8.11.4 will mitigate this issue otherwise.
also known as (5)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (6)
External citations — patches, advisories, analysis.
- https://cxsecurity.com/cveshow/CVE-2024-45217/cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2024-45217cnnvd
- https://solr.apache.org/security.html#cve-2024-45217-apache-solr-configsets-created-during-a-backup-restore-command-are-trusted-implicitlycnnvd
- https://solr.apache.org/security.html#cve-2024-45217-apache-solr-configsets-created-during-a-backup-restore-command-are-trusted-implicitlyenisa_euvd
- http://www.openwall.com/lists/oss-security/2024/10/15/9Mailing Listnvd
- https://solr.apache.org/security.html#cve-2024-45217-apache-solr-configsets-created-during-a-backup-restore-command-are-trusted-implicitlyVendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan