CVE-2024-39877
highpriority · track · 36EPSS 0.017 · 77 %ileEURUUSEPSS · scored 2026-10-22
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (5)
Products and version ranges known to be affected.
advisories (3)
Vendor and ecosystem advisories describing this.
- GHSA-g5hv-r743-v8pmApache Airflow has DAG Author Code Execution possibility in airflow-scheduler2024-07-17ghsa · osvUS
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
- BIT-airflow-2024-39877Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler2024-07-19vendor · osvUS
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
- PYSEC-2024-1902024-07-17vendor · osvUS
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
also known as (8)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (8)
External citations — patches, advisories, analysis.
- https://cxsecurity.com/cveshow/CVE-2024-39877/cnnvd
- https://github.com/apache/airflow/pull/40522cnnvd
- https://lists.apache.org/thread/1xhj9dkp37d6pzn24ll2mf94wbqnb2y1cnnvd
- https://github.com/apache/airflow/pull/40522enisa_euvd
- https://lists.apache.org/thread/1xhj9dkp37d6pzn24ll2mf94wbqnb2y1enisa_euvd
- http://www.openwall.com/lists/oss-security/2024/07/16/7nvd
- https://github.com/apache/airflow/pull/40522Issue TrackingPatchnvd
- https://lists.apache.org/thread/1xhj9dkp37d6pzn24ll2mf94wbqnb2y1Mailing Listnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan