CVE-2024-38474
criticalpriority · track · 40EPSS 0.025 · 84 %ileDEEUNLRUUSEPSS · scored 2026-10-24
Substitution encoding issue in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows attacker to execute scripts in directories permitted by the configuration but not directly reachable by any URL or source disclosure of scripts meant to only to be executed as CGI. Users are recommended to upgrade to version 2.4.60, which fixes this issue. Some RewriteRules that capture and substitute unsafely will now fail unless rewrite flag "UnsafeAllow3F" is specified.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · high–critical · 8.1–9.8
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (102)
Products and version ranges known to be affected.
- IBM Business Automation Workflow 24.0.0all versionscert_bundDEcpe:/a:ibm:business_automation_workflow:24.0.0
advisories (4)
Vendor and ecosystem advisories describing this.
- NCSC-2024-0275Kwetsbaarheden verholpen in Apache HHTP-serverNL2024-07-02csaf · ncsc_nlNL
Apache Software Foundation heeft kwetsbaarheden verholpen in de Apache HTTP-Server.
- NCSC-2024-0411Kwetsbaarheden verholpen in Oracle Database productenNL2024-10-17csaf · ncsc_nlNL
Oracle heeft kwetsbaarheden verholpen in diverse Database producten en subsystemen, zoals de Core database, Application Express, Autonomous Health Framework, Essbase, GoldenGate, SQL Developer en Secure Backup.
- WID-SEC-W-2024-1504Apache HTTP Server: Mehrere SchwachstellenDeutsch2024-07-01csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Apache HTTP Server ausnutzen, um beliebigen Code auszuführen, einen Denial-of-Service-Zustand herbeizuführen, Sicherheitsmaßnahmen zu umgehen oder vertrauliche Informationen offenzulegen.
- BIT-apache-2024-38474Apache HTTP Server weakness with encoded question marks in backreferences2024-07-03vendor · osvUS
Substitution encoding issue in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows attacker to execute scripts in directories permitted by the configuration but not directly reachable by any URL or source disclosure of scripts meant to only to be executed as CGI. Users are recommended to upgrade to version 2.4.60, which fixes this issue. Some RewriteRules that capture and substitute unsafely will now fail unless rewrite flag "UnsafeAllow3F" is specified.
also known as (4)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (10)
External citations — patches, advisories, analysis.
- https://cnnvd
- https://access.redhat.com/security/cve/cve-2024-38474cnnvd
- https://cxsecurity.com/cveshow/CVE-2024-38474/cnnvd
- https://httpd.apache.org/security/vulnerabilities_24.htmlPatchcnnvd
- https://vigilance.fr/vulnerability/Apache-cnnvd
- https://httpd.apache.org/security/vulnerabilities_24.htmlenisa_euvd
- https://security.netapp.com/advisory/ntap-20240712-0001/enisa_euvd
- http://www.openwall.com/lists/oss-security/2024/07/01/7nvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan