CVE-2024-24773
mediumpriority · track · 26OT risk · elevatedEPSS 0.008 · 56 %ileDEEUUSEPSS · scored 2026-10-27
Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (8)
Products and version ranges known to be affected.
advisories (4)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2024-0515Apache Superset: Mehrere Schwachstellen ermöglichen Manipulation von DateienDeutsch2024-02-28csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in Apache Superset ausnutzen, um Dateien zu manipulieren.
- GHSA-5474-f7g5-273qApache Superset: Improper validation of SQL statements allows for unauthorized access to data2024-02-28ghsa · osvUS
Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.
- BIT-superset-2024-24773Apache Superset: Improper validation of SQL statements allows for unauthorized access to data2025-02-05vendor · osvUS
Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.
- PYSEC-2026-1160Apache Superset: Improper validation of SQL statements allows for unauthorized access to data2026-07-07vendor · osvUS
Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.
also known as (7)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (7)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2024/02/28/4cnnvd
- https://cxsecurity.com/cveshow/CVE-2024-24773/cnnvd
- https://lists.apache.org/thread/h66fy6nj41cfx07zh7l552w6dmtjh501cnnvd
- http://www.openwall.com/lists/oss-security/2024/02/28/4enisa_euvd
- https://lists.apache.org/thread/h66fy6nj41cfx07zh7l552w6dmtjh501enisa_euvd
- http://www.openwall.com/lists/oss-security/2024/02/28/4Mailing ListThird Party Advisorynvd
- https://lists.apache.org/thread/h66fy6nj41cfx07zh7l552w6dmtjh501Mailing ListVendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan