CVE-2024-24772
mediumpriority · track · 17EPSS 0.010 · 61 %ileDEEUUSEPSS · scored 2026-10-27
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (8)
Products and version ranges known to be affected.
advisories (4)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2024-0515Apache Superset: Mehrere Schwachstellen ermöglichen Manipulation von DateienDeutsch2024-02-28csaf · cert_bundDE
Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in Apache Superset ausnutzen, um Dateien zu manipulieren.
- GHSA-m6jm-3v38-76j4Apache Superset: Improper Neutralization of custom SQL on embedded context2024-02-28ghsa · osvUS
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
- BIT-superset-2024-24772Apache Superset: Improper Neutralisation of custom SQL on embedded context2025-02-05vendor · osvUS
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
- PYSEC-2026-1185Apache Superset: Improper Neutralization of custom SQL on embedded context2026-07-07vendor · osvUS
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
also known as (7)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (7)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2024/02/28/5cnnvd
- https://access.redhat.com/security/cve/cve-2024-24772cnnvd
- https://cxsecurity.com/cveshow/CVE-2024-24772/cnnvd
- https://lists.apache.org/thread/gfl3ckwy6y9tpz9jmpv62orh2q346sn5cnnvd
- https://lists.apache.org/thread/gfl3ckwy6y9tpz9jmpv62orh2q346sn5enisa_euvd
- http://www.openwall.com/lists/oss-security/2024/02/28/5Mailing ListThird Party Advisorynvd
- https://lists.apache.org/thread/gfl3ckwy6y9tpz9jmpv62orh2q346sn5Mailing ListVendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan