CVE-2024-21910
mediumpriority · track · 24EPSS 0.010 · 61 %ileEUUSEPSS · scored 2026-10-27
TinyMCE versions before 5.10.0 are affected by a cross-site scripting vulnerability. A remote and unauthenticated attacker could introduce crafted image or link URLs that would result in the execution of arbitrary JavaScript in an editing user's browser.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (5)
Products and version ranges known to be affected.
advisories (2)
Vendor and ecosystem advisories describing this.
- GHSA-r8hm-w5f7-wj39Cross-site scripting vulnerability in TinyMCE plugins2021-11-02ghsa · osvUS
### Impact A cross-site scripting (XSS) vulnerability was discovered in the URL processing logic of the `image` and `link` plugins. The vulnerability allowed arbitrary JavaScript execution when updating an image or link using a specially crafted URL. This issue only impacted users while editing and the dangerous URLs were stripped in any content extracted from the editor. This impacts all users who are using TinyMCE 5.9.2 or lower. ### Patches This vulnerability has been patched in TinyMCE 5.10.0 by improved sanitization logic when updating URLs in the relevant plugins. ### Workarounds To work around this vulnerability, either: - Upgrade to TinyMCE 5.10.0 or higher - Disable the `image` and `link` plugins ### Acknowledgements Tiny Technologies would like to thank Yakir6 for discovering this vulnerability. ### References https://www.tiny.cloud/docs/release-notes/release-notes510/#securityfixes ### For more information If you have any questions or comments about this advisory: * Email us at [infosec@tiny.cloud](mailto:infosec@tiny.cloud) * Open an issue in the [TinyMCE repo](https://github.com/tinymce/tinymce/issues)
- PYSEC-2026-632Cross-site scripting vulnerability in TinyMCE plugins2026-07-02vendor · osvUS
### Impact A cross-site scripting (XSS) vulnerability was discovered in the URL processing logic of the `image` and `link` plugins. The vulnerability allowed arbitrary JavaScript execution when updating an image or link using a specially crafted URL. This issue only impacted users while editing and the dangerous URLs were stripped in any content extracted from the editor. This impacts all users who are using TinyMCE 5.9.2 or lower. ### Patches This vulnerability has been patched in TinyMCE 5.10.0 by improved sanitization logic when updating URLs in the relevant plugins. ### Workarounds To work around this vulnerability, either: - Upgrade to TinyMCE 5.10.0 or higher - Disable the `image` and `link` plugins ### Acknowledgements Tiny Technologies would like to thank Yakir6 for discovering this vulnerability. ### References https://www.tiny.cloud/docs/release-notes/release-notes510/#securityfixes ### For more information If you have any questions or comments about this advisory: * Email us at [infosec@tiny.cloud](mailto:infosec@tiny.cloud) * Open an issue in the [TinyMCE repo](https://github.com/tinymce/tinymce/issues)
also known as (6)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (20)
External citations — patches, advisories, analysis.
- https://access.redhat.com/security/cve/cve-2024-21910cnnvd
- https://cxsecurity.com/cveshow/CVE-2024-21910/cnnvd
- https://github.com/advisories/GHSA-r8hm-w5f7-wj39cnnvd
- https://github.com/jazzband/django-tinymce/issues/366cnnvd
- https://github.com/jazzband/django-tinymce/releases/tag/3.4.0cnnvd
- https://github.com/tinymce/tinymce/security/advisories/GHSA-r8hm-w5f7-wj39cnnvd
- https://pypi.org/project/django-tinymce/3.4.0/cnnvd
- https://vulncheck.com/advisories/vc-advisory-GHSA-r8hm-w5f7-wj39cnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan