CVE-2024-21520
mediumpriority · track · 10EPSS 0.011 · 66 %ileexploit · PoCDEEUUSEPSS · scored 2026-10-22
Versions of the package djangorestframework before 3.15.2 are vulnerable to Cross-site Scripting (XSS) via the break_long_headers template filter due to improper input sanitization before splitting and joining with <br> tags.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- Fixedpython311-djangorestframework-0:3.16.1-2.1.aarch64 as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedpython311-djangorestframework-0:3.16.1-2.1.ppc64le as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedpython311-djangorestframework-0:3.16.1-2.1.s390x as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedpython311-djangorestframework-0:3.16.1-2.1.x86_64 as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedpython312-djangorestframework-0:3.16.1-2.1.aarch64 as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedpython312-djangorestframework-0:3.16.1-2.1.ppc64le as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedpython312-djangorestframework-0:3.16.1-2.1.s390x as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedpython312-djangorestframework-0:3.16.1-2.1.x86_64 as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedpython313-djangorestframework-0:3.16.1-2.1.aarch64 as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedpython313-djangorestframework-0:3.16.1-2.1.ppc64le as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedpython313-djangorestframework-0:3.16.1-2.1.s390x as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedpython313-djangorestframework-0:3.16.1-2.1.x86_64 as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 2.1–6.1
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
exploits (1)
Public proof-of-concept and weaponised exploit code.
affected products (6)
Products and version ranges known to be affected.
- Red Hat Ansible Automation Platform 2.4all versionscert_bundDEcpe:/a:redhat:ansible_automation_platform:2.4
advisories (4)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2024-2229Red Hat Ansible Automation Platform: Mehrere SchwachstellenDeutsch2024-09-26csaf · cert_bundDE
Ein entfernter Angreifer kann mehrere Schwachstellen in Red Hat Ansible Automation Platform ausnutzen, um einen Cross-Site Scripting Angriff durchzuführen oder vertrauliche Informationen offenzulegen.
- openSUSE-SU-2026:10115-1python311-djangorestframework-3.16.1-2.1 on GA media2026-01-29csaf · suse_csafDE
python311-djangorestframework-3.16.1-2.1 on GA media
- GHSA-gw84-84pc-xp82Cross-site Scripting in djangorestframework2024-06-26ghsa · osvUS
Versions of the package djangorestframework before 3.15.2 are vulnerable to Cross-site Scripting (XSS) via the break_long_headers template filter due to improper input sanitization before splitting and joining with <br> tags.
- PYSEC-2026-1304Cross-site Scripting in djangorestframework2026-07-07vendor · osvUS
Versions of the package djangorestframework before 3.15.2 are vulnerable to Cross-site Scripting (XSS) via the break_long_headers template filter due to improper input sanitization before splitting and joining with <br> tags.
also known as (6)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (13)
External citations — patches, advisories, analysis.
- https://access.redhat.com/security/cve/cve-2024-21520cnnvd
- https://cxsecurity.com/cveshow/CVE-2024-21520/cnnvd
- https://github.com/encode/django-rest-framework/commit/3b41f0124194430da957b119712978fa2266b642cnnvd
- https://github.com/encode/django-rest-framework/pull/9435cnnvd
- https://security.snyk.io/vuln/SNYK-PYTHON-DJANGORESTFRAMEWORK-7252137cnnvd
- https://vigilance.fr/vulnerability/djangorestframework-Cross-Site-Scripting-via-break-long-headers-45215cnnvd
- https://github.com/encode/django-rest-framework/commit/3b41f0124194430da957b119712978fa2266b642enisa_euvd
- https://github.com/encode/django-rest-framework/pull/9435enisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan