CVE-2023-51437
highpriority · track · 30EPSS 0.008 · 55 %ileEURUUSEPSS · scored 2026-10-28
Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6.8–7.4
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (16)
Products and version ranges known to be affected.
- Maven org.apache.pulsar:pulsar-broker-auth-sasl< 2.11.3osvUSpkg:maven/org.apache.pulsar/pulsar-broker-auth-sasl
- Maven org.apache.pulsar:pulsar-broker-auth-sasl3.0.0 → 3.0.2osvUSpkg:maven/org.apache.pulsar/pulsar-broker-auth-sasl
- Maven org.apache.pulsar:pulsar-broker-auth-sasl3.1.0 → 3.1.1osvUSpkg:maven/org.apache.pulsar/pulsar-broker-auth-sasl
advisories (1)
Vendor and ecosystem advisories describing this.
- GHSA-c57v-4vg5-cm2xApache Pulsar SASL Authentication Provider observable timing discrepancy vulnerability2024-02-07ghsa · osvUS
Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .
also known as (4)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (8)
External citations — patches, advisories, analysis.
- http://www.openwall.com/lists/oss-security/2024/02/07/1cnnvd
- https://cxsecurity.com/cveshow/CVE-2023-51437/cnnvd
- https://lists.apache.org/thread/5kgmvvolf5tzp5rz9xjwfg2ncwvqqgl5cnnvd
- https://www.openwall.com/lists/oss-security/2024/02/07/1cnnvd
- https://lists.apache.org/thread/5kgmvvolf5tzp5rz9xjwfg2ncwvqqgl5enisa_euvd
- https://www.openwall.com/lists/oss-security/2024/02/07/1enisa_euvd
- https://lists.apache.org/thread/5kgmvvolf5tzp5rz9xjwfg2ncwvqqgl5Issue TrackingVendor Advisorynvd
- https://www.openwall.com/lists/oss-security/2024/02/07/1nvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan