CVE-2023-39418
mediumpriority · track · 17OT risk · elevatedEPSS 0.011 · 65 %ileDEEURUUSEPSS · scored 2026-10-27
A vulnerability was found in PostgreSQL with the use of the MERGE command, which fails to test new rows against row security policies defined for UPDATE and SELECT. If UPDATE and SELECT policies forbid some rows that INSERT policies do not forbid, a user could store such rows.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- FixedSINEC NMSsiemens_psirt
Update to V2.0 SP1 or later version
https://support.industry.siemens.com/cs/ww/en/view/109826954/ - FixedSINEC NMScisa_csaf_ot
Update to V2.0 SP1 or later version
https://support.industry.siemens.com/cs/ww/en/view/109826954/
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 3.1–4.3
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (30)
Products and version ranges known to be affected.
- Red Hat Red Hat Enterprise Linux 8.8 Extended Update Support< 8080020231113134015.63b34585enisa_euvdEU
advisories (4)
Vendor and ecosystem advisories describing this.
- SSA-943925SSA-943925: Multiple Vulnerabilities in SINEC NMS before V2.0 SP12024-02-13csaf · siemens_psirtDE
SINEC NMS before V2.0 SP1 is affected by multiple vulnerabilities. Siemens has released an update for SINEC NMS and recommends to update to the latest version.
- WID-SEC-W-2023-2038PostgreSQL: Mehrere SchwachstellenDeutsch2023-08-10csaf · cert_bundDE
Ein entfernter authentifizierter Angreifer kann mehrere Schwachstellen in PostgreSQL ausnutzen, um beliebigen Code auszuführen oder Sicherheitsmaßnahmen zu umgehen.
- ICSA-24-046-15Siemens SINEC NMS2024-02-13icsa · cisa_csaf_otUS
SINEC NMS before V2.0 SP1 is affected by multiple vulnerabilities. Siemens has released an update for SINEC NMS and recommends to update to the latest version.
- BIT-postgresql-2023-39418Postgresql: merge fails to enforce update or select row security policies2024-03-06vendor · osvUS
A vulnerability was found in PostgreSQL with the use of the MERGE command, which fails to test new rows against row security policies defined for UPDATE and SELECT. If UPDATE and SELECT policies forbid some rows that INSERT policies do not forbid, a user could store such rows.
also known as (4)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (28)
External citations — patches, advisories, analysis.
- https://access.redhat.com/security/cve/CVE-2023-39418cnnvd
- https://access.redhat.com/security/cve/cve-2023-39418cnnvd
- https://bugzilla.redhat.com/show_bug.cgi?id=2228112cnnvd
- https://cxsecurity.com/cveshow/CVE-2023-39418/cnnvd
- https://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=cb2ae5741f2458a474ed3c31458d242e678ff229cnnvd
- https://security.netapp.com/advisory/ntap-20230915-0002/cnnvd
- https://www.auscert.org.au/bulletins/ESB-2023.4767cnnvd
- https://www.auscert.org.au/bulletins/ESB-2023.6629cnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan