CVE-2023-35933
highpriority · track · 30EPSS 0.011 · 66 %ileEUUSEPSS · scored 2026-10-27
OPenFGA is an open source authorization/permission engine built for developers. OpenFGA versions v1.1.0 and prior are vulnerable to a DoS attack when Check and ListObjects calls are executed against authorization models that contain circular relationship definitions. Users are affected by this vulnerability if they are using OpenFGA v1.1.0 or earlier, and if you are executing `Check` or `ListObjects` calls against a vulnerable authorization model. Users are advised to upgrade to version 1.1.1. There are no known workarounds for this vulnerability. Users that do not have circular relationships in their models are not affected.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 5.9–7.5
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (3)
Products and version ranges known to be affected.
advisories (2)
Vendor and ecosystem advisories describing this.
- GHSA-hr9r-8phq-5x8jOpenFGA vulnerable to denial of service due to circular relationship2023-06-28ghsa · osvUS
### Overview OpenFGA versions v1.1.0 and prior are vulnerable to a DoS attack when certain Check and ListObjects calls are executed against authorization models that contain circular relationship definitions. ### Am I Affected? You are affected by this vulnerability if you are using OpenFGA v1.1.0 or earlier, and if you are executing certain [Check](https://openfga.dev/api/service#/Relationship%20Queries/Check) or [ListObjects](https://openfga.dev/api/service#/Relationship%20Queries/ListObjects) calls against a vulnerable authorization model. To see which of your models could be vulnerable to this attack, download OpenFGA v1.2.0 and run the following command: ``` ./openfga validate-models --datastore-engine <ENGINE> --datastore-uri <URI> | jq .[] | select(.Error | contains("loop")) ``` replacing the variables `<ENGINE>` and `<URI>` as needed. ### Fix Upgrade to v1.1.1. ### Backward Compatibility If you are not passing an invalid authorization model (as identified by running `./openfga validate-models`) as a parameter of your Check and ListObjects calls, this upgrade is backwards compatible. Otherwise, OpenFGA v1.1.1 will start returning HTTP 400 status codes on those calls.
- GO-2023-1872Denial of service in github.com/openfga/openfga2023-07-05vendor · osvUS
OpenFGA is vulnerable to a denial of service attack when certain Check and ListObjects calls are executed against authorization models that contain circular relationship definitions.
also known as (5)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (13)
External citations — patches, advisories, analysis.
- https://cxsecurity.com/cveshow/CVE-2023-35933/cnnvd
- https://github.com/openfga/openfga/commit/087ce392595f3c319ab3028b5089118ea4063452cnnvd
- https://github.com/openfga/openfga/security/advisories/GHSA-hr9r-8phq-5x8jcnnvd
- https://openfga.dev/api/service#/Relationship%20Queries/Checkcnnvd
- https://openfga.dev/api/service#/Relationship%20Queries/ListObjectscnnvd
- https://github.com/openfga/openfga/commit/087ce392595f3c319ab3028b5089118ea4063452enisa_euvd
- https://github.com/openfga/openfga/security/advisories/GHSA-hr9r-8phq-5x8jenisa_euvd
- https://openfga.dev/api/service#/Relationship%20Queries/Checkenisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan