CVE-2023-22512
highpriority · track · 35EPSS 0.151 · 97 %ileDEEURUUSEPSS · scored 2026-10-27
This High severity DoS (Denial of Service) vulnerability was introduced in version 5.6.0 of Confluence Data Center and Server. With a CVSS Score of 7.5, this vulnerability allows an unauthenticated attacker to cause a resource to be unavailable for its intended users by temporarily or indefinitely disrupting services of a vulnerable host (Confluence instance) connected to a network, which has no impact to confidentiality, no impact to integrity, high impact to availability, and requires no user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Confluence Data Center and Server 7.19: Upgrade to a release greater than or equal to 7.19.14 Confluence Data Center and Server 8.5: Upgrade to a release greater than or equal to 8.5.1 Confluence Data Center and Server 8.6 or above: No need to upgrade, you're already on a patched version See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html ). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives ]). This vulnerability was reported via our Bug Bounty program.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6.9–7.5
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (12)
Products and version ranges known to be affected.
- atlassian confluence data center5.6 → 7.19.14nvdUScpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:*
- atlassian confluence data center8.0.0 → 8.5.1nvdUScpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:*
advisories (1)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2023-2392Atlassian Confluence: Schwachstelle ermöglicht Denial of ServiceDeutsch2023-09-19csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann eine Schwachstelle in Atlassian Confluence ausnutzen, um einen Denial of Service Angriff durchzuführen.
also known as (4)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (9)
External citations — patches, advisories, analysis.
- https://access.redhat.com/security/cve/cve-2023-22512cnnvd
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1283691616cnnvd
- https://cxsecurity.com/cveshow/CVE-2023-22512/cnnvd
- https://jira.atlassian.com/browse/CONFSERVER-91258cnnvd
- https://www.auscert.org.au/bulletins/ESB-2023.5394cnnvd
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1283691616enisa_euvd
- https://jira.atlassian.com/browse/CONFSERVER-91258enisa_euvd
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1283691616Vendor Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan