CVE-2023-0872

highpriority · track · 43EPSS 0.033 · 89 %ileexploit · weaponizedEUUS
grimoire priorityP1 · Urgent
Exploitable?
Public exploit
1 exploit · weaponized
Likely / severe?
3.31% (89th) EPSS
CVSS 8 · high
Is it mine?
11 products
Check your exposure
Who says so?
4 sources
cnnvd · enisa_euvd · nvd · osv

EPSS · scored 2026-10-28

The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.

01

cvss

Technical severity, 0–10. One row per scoring source.

8.2
010

base score 0–10 · higher = more severe · hover a vector to decode

v3.18highCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:Hprimary · NVD / NIST USexploitability 2.1 · impact 5.9
v3.18.2highCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:Lsecondary · ENISA EU
v3.18.2highCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:Lsecondary · security@opennms.comexploitability 2.3 · impact 5.3
v3.18.2highCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:Lsecondary · OSV
v3.17.8highCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:Fsecondary · CVSS-BT (t0sche)
02

ssvc

A stakeholder decision — act, attend, or track — from exploitation and impact.

Trackcoordinatorcisa_ssvcUS
03

weaknesses

The CWE weakness classes this flaw belongs to.

04

exploits (1)

Public proof-of-concept and weaponised exploit code.

05

affected products (11)

Products and version ranges known to be affected.

06

advisories (1)

Vendor and ecosystem advisories describing this.

  • GHSA-w5gq-xrrp-3fxfOpenNMS privilege elevation vulnerability2023-08-14ghsa · osvUS

    The Horizon REST API includes a users endpoint in OpenNMS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.

07

also known as (3)

Other names and identifiers for this entity.

08

sources

Which sources assert this record, and when.

published 2023-08-14modified 2026-06-17
09

references (8)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan