CVE-2022-43995
highpriority · track · 28EPSS 0.003 · 21 %ileDEEURUUSEPSS · scored 2026-10-27
Sudo 1.8.0 through 1.9.12, with the crypt() password backend, contains a plugins/sudoers/auth/passwd.c array-out-of-bounds error that can result in a heap-based buffer over-read. This can be triggered by arbitrary local users with access to Sudo by entering a password of seven characters or fewer. The impact could vary depending on the system libraries, compiler, and processor architecture.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- Fixedphoenix_contact_psirt
Update to the latest 2023.0.0 LTS Firmware Release. PHOENIX CONTACT recommends to always use an up-to-date version of the PLCnext Engineer.
- Mitigationphoenix_contact_psirt
Phoenix Contact recommends operating network-capable devices in closed networks or protected with a suitable firewall. For detailed information on our recommendations for measures to protect network-capable devices, please refer to our application note: Measures to protect network-capable devices with Ethernet connection
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6.5–7.1
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (27)
Products and version ranges known to be affected.
advisories (4)
Vendor and ecosystem advisories describing this.
- VDE-2023-001PHOENIX CONTACT: Multiple Vulnerabilities in PLCnext Firmware2023-02-14csaf · phoenix_contact_psirtDE
A new LTS Firmware release fixes known vulnerabilities in used open-source libraries. In addition, the following improvements have been implemented: HMI - Hardening against DoS attacks. - Hardening against memory leak problems in case of network attacks. WBM - Umlauts in the password of the 'User Manager' were not handled correctly. The password rule for upper and lower case was not followed. This could lead to unintentionally weaker passwords.- Hardening of WBM against Cross-Site-Scripting. User Manager - In security notifications 'SecurityToken' was always displayed as '0000000' when creating or modifying users.- Hardening of Trust and Identity Stores.
- WID-SEC-W-2022-1956sudo: Schwachstelle ermöglicht nicht spezifizierten AngriffDeutsch2022-11-03csaf · cert_bundDE
Ein lokaler Angreifer kann eine Schwachstelle in sudo ausnutzen, um einen nicht näher spezifizierten Angriff durchzuführen.
- WID-SEC-W-2023-0296Meinberg LANTIME: Mehrere SchwachstellenDeutsch2023-02-06csaf · cert_bundDE
Ein lokaler Angreifer kann mehrere Schwachstellen in Meinberg LANTIME ausnutzen, um seine Privilegien zu erhöhen, um einen Denial of Service Zustand herbeizuführen und um nicht näher beschriebene Auswirkungen zu verursachen.
- WID-SEC-W-2024-0794Dell ECS: Mehrere SchwachstellenDeutsch2024-04-04csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Dell ECS ausnutzen, um seine Privilegien zu erweitern, beliebigen Programmcode mit Administratorrechten auszuführen, Informationen offenzulegen, Dateien zu manipulieren, einen Cross-Site-Scripting-Angriff durchzuführen, Sicherheitsvorkehrungen zu umgehen oder einen Denial of Service Zustand herbeizuführen.
also known as (4)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (21)
External citations — patches, advisories, analysis.
- https://bugzilla.redhat.com/show_bug.cgi?id=2139911cnnvd
- https://cxsecurity.com/cveshow/CVE-2022-43995/cnnvd
- https://github.com/sudo-project/sudo/commit/bd209b9f16fcd1270c13db27ae3329c677d48050cnnvd
- https://news.ycombinator.com/item?id=33465707cnnvd
- https://packetstormsecurity.com/files/169985/Gentoo-Linux-Security-Advisory-202211-08.htmlcnnvd
- https://security.gentoo.org/glsa/202211-08cnnvd
- https://vigilance.fr/vulnerability/Sudo-buffer-overflow-via-LZ4-Compression-Codec-Upper-39834cnnvd
- https://vigilance.fr/vulnerability/Sudo-buffer-overflow-via-Small-Passwords-39834cnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan