CVE-2022-41742
highpriority · track · 28EPSS 0.012 · 68 %ileDEEUNLRUUSEPSS · scored 2026-10-27
NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to cause a worker process crash, or might result in worker process memory disclosure by using a specially crafted audio or video file. The issue affects only NGINX products that are built with the module ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- FixedSINEC Traffic Analyzer (6GK8822-1BG01-0BA0)siemens_psirt
Update to V1.2 or later version
https://support.industry.siemens.com/cs/ww/en/view/109954887/ - FixedSINEC Traffic Analyzer (6GK8822-1BG01-0BA0)cisa_csaf_ot
Update to V1.2 or later version
https://support.industry.siemens.com/cs/ww/en/view/109954887/
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6.7–7.1
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (58)
Products and version ranges known to be affected.
advisories (7)
Vendor and ecosystem advisories describing this.
- NCSC-2024-0246Kwetsbaarheden verholpen in Siemens productenNL2024-06-11csaf · ncsc_nlNL
Siemens heeft kwetsbaarheden verholpen in diverse producten, zoals SCALANCE, SICAM, Tecnomatix, SITOP en PowerSys.
- SSA-196737SSA-196737: Multiple Vulnerabilities in SINEC Traffic Analyzer Before V1.22024-06-11csaf · siemens_psirtDE
SINEC Traffic Analyzer before V1.2 is affected by multiple vulnerabilities. Siemens has released a new version for SINEC Traffic Analyzer and recommends to update to the latest version.
- WID-SEC-W-2022-1803NGINX und NGINX Plus: Mehrere SchwachstellenDeutsch2022-10-19csaf · cert_bundDE
Ein lokaler Angreifer kann mehrere Schwachstellen in NGINX Plus und NGINX ausnutzen, um einen Denial of Service Angriff durchzuführen und vertrauliche Informationen offenzulegen oder sonstige Auswirkungen zu verursachen.
- WID-SEC-W-2024-1591Juniper JUNOS: Mehrere SchwachstellenDeutsch2024-07-10csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Juniper JUNOS ausnutzen, um einen Denial of Service zu verursachen, Informationen offenzulegen, Privilegien zu erweitern und Sicherheitsmechanismen inklusive zu umgehen.
- ICSA-24-165-13Siemens SINEC Traffic Analyzer 2024-06-11icsa · cisa_csaf_otUS
SINEC Traffic Analyzer before V1.2 is affected by multiple vulnerabilities. Siemens has released a new version for SINEC Traffic Analyzer and recommends to update to the latest version.
- BIT-nginx-2022-41742NGINX ngx_http_mp4_module vulnerability CVE-2022-417422024-03-06vendor · osvUS
NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to cause a worker process crash, or might result in worker process memory disclosure by using a specially crafted audio or video file. The issue affects only NGINX products that are built with the module ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.
- BIT-nginx-ingress-controller-2022-417422023-11-06vendor · osvUS
NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to cause a worker process crash, or might result in worker process memory disclosure by using a specially crafted audio or video file. The issue affects only NGINX products that are built with the module ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.
also known as (6)
Other names and identifiers for this entity.
- CNNVD-202210-1409cnnvd
- EUVD-2022-44913enisa_euvd
- BDU:2022-06441fstec_bdu
- GHSA-wj45-j4gh-fm3xenisa_euvd
- BIT-nginx-2022-41742osv
- BIT-nginx-ingress-controller-2022-41742osv
sources
Which sources assert this record, and when.
references (27)
External citations — patches, advisories, analysis.
- https://cxsecurity.com/cveshow/CVE-2022-41742/cnnvd
- https://lists.debian.org/debian-lts-announce/2022/11/msg00031.htmlcnnvd
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/BPRVYA4FS34VWB4FEFYNAD7Z2LFCJVEI/cnnvd
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FD6M3PVVKO35WLAA7GLDBS6TEQ26SM64/cnnvd
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WBORRVG7VVXYOAIAD64ZHES2U2VIUKFQ/cnnvd
- https://packetstormsecurity.com/files/169909/Debian-Security-Advisory-5281-1.htmlcnnvd
- https://security.netapp.com/advisory/ntap-20230120-0005/cnnvd
- https://support.f5.com/csp/article/K28112382cnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan