CVE-2022-30122
highpriority · track · 31EPSS 0.022 · 83 %ileDEEURUUSEPSS · scored 2026-10-27
A possible denial of service vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 in the multipart parsing component of Rack.
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- Fixedrubygem-rack-0:2.2.3.1-1.el8sat.noarch as a component of Red Hat Satellite 6.11 for RHEL 8redhat_csaf
Before applying this update, make sure all previously released errata relevant to your system have been applied. For detailed instructions how to apply this update, refer to: https://access.redhat.com/documentation/en-us/red_hat_satellite/6.11/html/upgrading_and_updating_red_hat_satellite/index
https://access.redhat.com/errata/RHSA-2022:7242 - Fixedrubygem-rack-0:2.2.3.1-1.el8sat.src as a component of Red Hat Satellite 6.11 for RHEL 8redhat_csaf
Before applying this update, make sure all previously released errata relevant to your system have been applied. For detailed instructions how to apply this update, refer to: https://access.redhat.com/documentation/en-us/red_hat_satellite/6.11/html/upgrading_and_updating_red_hat_satellite/index
https://access.redhat.com/errata/RHSA-2022:7242 - Fixedtfm-rubygem-rack-0:2.2.3.1-1.el7sat.noarch as a component of Red Hat Satellite 6.11 for RHEL 7redhat_csaf
Before applying this update, make sure all previously released errata relevant to your system have been applied. For detailed instructions how to apply this update, refer to: https://access.redhat.com/documentation/en-us/red_hat_satellite/6.11/html/upgrading_and_updating_red_hat_satellite/index
https://access.redhat.com/errata/RHSA-2022:7242 - Fixedtfm-rubygem-rack-0:2.2.3.1-1.el7sat.src as a component of Red Hat Satellite 6.11 for RHEL 7redhat_csaf
Before applying this update, make sure all previously released errata relevant to your system have been applied. For detailed instructions how to apply this update, refer to: https://access.redhat.com/documentation/en-us/red_hat_satellite/6.11/html/upgrading_and_updating_red_hat_satellite/index
https://access.redhat.com/errata/RHSA-2022:7242 - Fixedruby4.0-rubygem-rack-2.2-0:2.2.22-1.1.aarch64 as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-rack-2.2-0:2.2.22-1.1.ppc64le as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-rack-2.2-0:2.2.22-1.1.s390x as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-rack-2.2-0:2.2.22-1.1.x86_64 as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-rack-0:3.1.18-1.3.aarch64 as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-rack-0:3.1.18-1.3.ppc64le as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-rack-0:3.1.18-1.3.s390x as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
- Fixedruby4.0-rubygem-rack-0:3.1.18-1.3.x86_64 as component of openSUSE Tumbleweedsuse_csaf
To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 5.3–7.5
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (115)
Products and version ranges known to be affected.
advisories (6)
Vendor and ecosystem advisories describing this.
- RHSA-2022:7242Red Hat Security Advisory: Satellite 6.11.4 Async Security Update2022-10-27csaf · redhat_csafUS
Updated Satellite 6.11 packages that fix several bugs are now available for Red Hat Satellite.
- WID-SEC-W-2022-0262Ruby: Mehrere SchwachstellenDeutsch2022-06-09csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Ruby ausnutzen, um einen Denial of Service Angriff durchzuführen, einen Cross-Site-Scripting-Angriff durchzuführen oder beliebigen Programmcode auszuführen.
- WID-SEC-W-2022-1905Red Hat Satellite: Mehrere SchwachstellenDeutsch2022-10-30csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Red Hat Satellite ausnutzen, um einen Denial of Service Angriff durchzuführen und beliebigen Code auszuführen.
- openSUSE-SU-2026:10286-1ruby4.0-rubygem-rack-2.2-2.2.22-1.1 on GA media2026-03-04csaf · suse_csafDE
ruby4.0-rubygem-rack-2.2-2.2.22-1.1 on GA media
- openSUSE-SU-2026:10358-1ruby4.0-rubygem-rack-3.1.18-1.3 on GA media2026-03-13csaf · suse_csafDE
ruby4.0-rubygem-rack-3.1.18-1.3 on GA media
- GHSA-hxqx-xwvh-44m2Denial of Service Vulnerability in Rack Multipart Parsing2022-05-27ghsa · osvUS
There is a possible denial of service vulnerability in the multipart parsing component of Rack. This vulnerability has been assigned the CVE identifier CVE-2022-30122. Versions Affected: >= 1.2 Not affected: < 1.2 Fixed Versions: 2.0.9.1, 2.1.4.1, 2.2.3.1 ## Impact Carefully crafted multipart POST requests can cause Rack's multipart parser to take much longer than expected, leading to a possible denial of service vulnerability. Impacted code will use Rack's multipart parser to parse multipart posts. This includes directly using the multipart parser like this: ``` params = Rack::Multipart.parse_multipart(env) ``` But it also includes reading POST data from a Rack request object like this: ``` p request.POST # read POST data p request.params # reads both query params and POST data ``` All users running an affected release should either upgrade or use one of the workarounds immediately. ## Workarounds There are no feasible workarounds for this issue.
also known as (4)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (22)
External citations — patches, advisories, analysis.
- https://cxsecurity.com/cveshow/CVE-2022-30122/cnnvd
- https://discuss.rubyonrails.org/t/cve-2022-30122-denial-of-service-vulnerability-in-rack-multipart-parsing/80729cnnvd
- https://packetstormsecurity.com/files/169562/Red-Hat-Security-Advisory-2022-7242-01.htmlcnnvd
- https://security.gentoo.org/glsa/202310-18cnnvd
- https://vigilance.fr/vulnerability/RubyGem-Rack-denial-of-service-via-Multipart-POST-Request-38680cnnvd
- https://www.auscert.org.au/bulletins/ESB-2022.3149cnnvd
- https://www.auscert.org.au/bulletins/ESB-2022.3589cnnvd
- https://www.auscert.org.au/bulletins/ESB-2022.4351cnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan