CVE-2022-24897
mediumpriority · track · 41EPSS 0.018 · 78 %ileexploit · PoCEUUSEPSS · scored 2026-10-27
APIs to evaluate content with Velocity is a package for APIs to evaluate content with Velocity. Starting with version 2.3 and prior to 12.6.7, 12.10.3, and 13.0, the velocity scripts are not properly sandboxed against using the Java File API to perform read or write operations on the filesystem. Writing an attacking script in Velocity requires the Script rights in XWiki so not all users can use it, and it also requires finding an XWiki API which returns a File. The problem has been patched in versions 12.6.7, 12.10.3, and 13.0. There is no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6–7.5
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
exploits (1)
Public proof-of-concept and weaponised exploit code.
affected products (6)
Products and version ranges known to be affected.
- Maven org.xwiki.commons:xwiki-commons-velocity12.7.0 → 12.10.3osvUSpkg:maven/org.xwiki.commons/xwiki-commons-velocity
- Maven org.xwiki.commons:xwiki-commons-velocity2.3.0 → 12.6.7osvUSpkg:maven/org.xwiki.commons/xwiki-commons-velocity
advisories (1)
Vendor and ecosystem advisories describing this.
- GHSA-cvx5-m8vg-vxgcArbitrary filesystem write access from velocity.2022-04-28ghsa · osvUS
### Impact The velocity scripts is not properly sandboxed against using the Java File API to perform read or write operations on the filesystem. Now writing an attacking script in velocity requires the Script rights in XWiki so not all users can use it, and it also requires finding an XWiki API which returns a File. ### Patches The problem has been patched on versions 12.6.7, 12.10.3 and 13.0RC1. ### Workarounds There's no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights. ### References https://jira.xwiki.org/browse/XWIKI-5168 ### For more information If you have any questions or comments about this advisory: * Open an issue in [Jira XWiki](https://jira.xwiki.org) * Email us at [XWiki Security mailing-list](mailto:security@xwiki.org)
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (13)
External citations — patches, advisories, analysis.
- https://cxsecurity.com/cveshow/CVE-2022-24897/cnnvd
- https://github.com/xwiki/xwiki-commons/commit/215951cfb0f808d0bf5b1097c9e7d1e503449ab8cnnvd
- https://github.com/xwiki/xwiki-commons/pull/127cnnvd
- https://github.com/xwiki/xwiki-commons/security/advisories/GHSA-cvx5-m8vg-vxgccnnvd
- https://jira.xwiki.org/browse/XWIKI-5168cnnvd
- https://github.com/xwiki/xwiki-commons/commit/215951cfb0f808d0bf5b1097c9e7d1e503449ab8enisa_euvd
- https://github.com/xwiki/xwiki-commons/pull/127enisa_euvd
- https://github.com/xwiki/xwiki-commons/security/advisories/GHSA-cvx5-m8vg-vxgcenisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan