CVE-2022-24750
highpriority · track · 31EPSS 0.003 · 20 %ileEUUSEPSS · scored 2026-10-28
UltraVNC is a free and open source remote pc access software. A vulnerability has been found in versions prior to 1.3.8.0 in which the DSM plugin module, which allows a local authenticated user to achieve local privilege escalation (LPE) on a vulnerable system. The vulnerability has been fixed to allow loading of plugins from the installed directory. Affected users should upgrade their UltraVNC to 1.3.8.1. Users unable to upgrade should not install and run UltraVNC server as a service. It is advisable to create a scheduled task on a low privilege account to launch WinVNC.exe instead. There are no known workarounds if winvnc needs to be started as a service.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (2)
Products and version ranges known to be affected.
also known as (2)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (10)
External citations — patches, advisories, analysis.
- https://cxsecurity.com/cveshow/CVE-2022-24750/cnnvd
- https://github.com/bowtiejicode/UltraVNC-DSMPlugin-LPEcnnvd
- https://github.com/ultravnc/UltraVNC/commit/36a31b37b98f70c1db0428f5ad83170d604fb352cnnvd
- https://github.com/ultravnc/UltraVNC/security/advisories/GHSA-3mvp-cp5x-vj5gcnnvd
- https://github.com/bowtiejicode/UltraVNC-DSMPlugin-LPEenisa_euvd
- https://github.com/ultravnc/UltraVNC/commit/36a31b37b98f70c1db0428f5ad83170d604fb352enisa_euvd
- https://github.com/ultravnc/UltraVNC/security/advisories/GHSA-3mvp-cp5x-vj5genisa_euvd
- https://github.com/bowtiejicode/UltraVNC-DSMPlugin-LPEPatchThird Party Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan