CVE-2022-0087

mediumpriority · track · 25EPSS 0.026 · 85 %ileEUUS
grimoire priorityP3 · Track
Exploitable?
—
no known exploitation
Likely / severe?
2.60% (85th) EPSS
CVSS 4.3 · medium
Is it mine?
4 products
Check your exposure
Who says so?
4 sources
cnnvd · enisa_euvd · nvd · osv

EPSS · scored 2026-10-28

keystone is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

01

cvss

Technical severity, 0–10. One row per scoring source.

7.1
010

base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 4.3–7.1

v2.04.3mediumAV:N/AC:M/Au:N/C:N/I:P/A:Nprimary · NVD / NIST USexploitability 8.6 · impact 2.9
v3.16.1mediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Nprimary · NVD / NIST USexploitability 2.8 · impact 2.7
v3.07.1highCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Lsecondary · ENISA EU
v3.07.1highCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Lsecondary · security@huntr.devexploitability 2.8 · impact 3.7
v3.07.1highCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Lsecondary · OSV
v3.16mediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:Fsecondary · CVSS-BT (t0sche)
02

weaknesses

The CWE weakness classes this flaw belongs to.

03

affected products (4)

Products and version ranges known to be affected.

04

advisories (1)

Vendor and ecosystem advisories describing this.

  • GHSA-hrgx-7j6v-xj82Reflected cross-site scripting (XSS) vulnerability2022-01-12ghsa · osvUS

    This security advisory relates to a capability for an attacker to exploit a reflected cross-site scripting vulnerability when using the `@keystone-6/auth` package. #### Impact The vulnerability can impact users of the administration user interface when following an untrusted link to the `signin` or `init` page. This is a targeted attack and may present itself in the form of phishing and or chained in conjunction with some other vulnerability. ## Vulnerability mitigation Please upgrade to `@keystone-6/auth >= 1.0.2`, where this vulnerability has been closed. If you are using `@keystone-next/auth`, we **strongly** recommend you upgrade to `@keystone-6`. ### Workarounds If for some reason you cannot upgrade the dependencies in software, you could alternatively - disable the administration user interface, or - if using a reverse-proxy, strip query parameters when accessing the administration interface ### References https://owasp.org/www-community/attacks/xss/ Thanks to Shivansh Khari (@Shivansh-Khari) for discovering and reporting this vulnerability

05

also known as (3)

Other names and identifiers for this entity.

06

sources

Which sources assert this record, and when.

published 2022-01-12modified 2026-06-17
07

references (7)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan