CVE-2021-4231
lowpriority · track · 22EPSS 0.012 · 68 %ileDEEUUSEPSS · scored 2026-10-27
A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 3.5–5.4
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (44)
Products and version ranges known to be affected.
- Red Hat Enterprise Linux Advanced Cluster Security for Kubernetes 4all versionscert_bundDEcpe:/o:redhat:enterprise_linux:advanced_cluster_security_for_kubernetes_4
- Red Hat Enterprise Linux Ceph Storage 6.1all versionscert_bundDEcpe:/o:redhat:enterprise_linux:ceph_storage_6.1
- Red Hat Enterprise Linux Service Interconnect 1all versionscert_bundDEcpe:/o:redhat:enterprise_linux:service_interconnect_1
- Red Hat OpenShift Container Platform 4.12all versionscert_bundDEcpe:/a:redhat:openshift:container_platform_4.12
advisories (3)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2023-1489Red Hat Enterprise Linux Ceph Storage: Mehrere SchwachstellenDeutsch2023-06-15csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Red Hat Enterprise Linux ausnutzen, um einen Cross-Site Scripting Angriff durchzuführen und einen Denial of Service Zustand auszulösen.
- WID-SEC-W-2023-1542Red Hat OpenShift: Mehrere SchwachstellenDeutsch2023-06-22csaf · cert_bundDE
Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Red Hat OpenShift ausnutzen, um einen Denial of Service Zustand herbeizuführen, Informationen offenzulegen, Dateien zu manipulieren oder Sicherheitsvorkehrungen zu umgehen.
- GHSA-c75v-2vq8-878fAngular vulnerable to Cross-site Scripting2022-05-27ghsa · osvUS
A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 10.2.5, 11.0.5 or 11.1.0-next.3 is advised to to address this issue.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (14)
External citations — patches, advisories, analysis.
- https://cxsecurity.com/cveshow/CVE-2021-4231/cnnvd
- https://github.com/angular/angular/commit/ba8da742e3b243e8f43d4c63aa842b44e14f2b09cnnvd
- https://github.com/angular/angular/issues/40136cnnvd
- https://security.snyk.io/vuln/SNYK-JS-ANGULARCORE-1070902cnnvd
- https://vuldb.com/?id.181356cnnvd
- https://www.auscert.org.au/bulletins/ESB-2023.3439cnnvd
- https://github.com/angular/angular/commit/ba8da742e3b243e8f43d4c63aa842b44e14f2b09enisa_euvd
- https://github.com/angular/angular/issues/40136enisa_euvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan