CVE-2021-39192
mediumpriority · track · 29EPSS 0.010 · 63 %ileEUUSEPSS · scored 2026-10-27
Ghost is a Node.js content management system. An error in the implementation of the limits service between versions 4.0.0 and 4.9.4 allows all authenticated users (including contributors) to view admin-level API keys via the integrations API endpoint, leading to a privilege escalation vulnerability. This issue is patched in Ghost version 4.10.0. As a workaround, disable all non-Administrator accounts to prevent API access. It is highly recommended to regenerate all API keys after patching or applying the workaround.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · medium–high · 6.5–7.2
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (4)
Products and version ranges known to be affected.
advisories (2)
Vendor and ecosystem advisories describing this.
- GHSA-j5c2-hm46-wp5cPrivilege escalation: all users can access Admin-level API keys2021-07-22ghsa · osvUS
### Impact An error in the implementation of the limits service in 4.0.0 allows all authenticated users (including contributors) to view admin-level API keys via the integrations API endpoint, leading to a privilege escalation vulnerability. Ghost(Pro) has already been patched. Self-hosters are impacted if running Ghost a version between 4.0.0 and 4.9.4. Immediate action should be taken to secure your site - see patches & workarounds below. It is highly recommended to regenerate all API keys after patching or applying the workaround below. ### Patches Fixed in 4.10.0, all 4.x sites should upgrade as soon as possible. ### Workarounds - Disable all non-Administrator accounts to prevent API access. ### For more information If you have any questions or comments about this advisory: * email us at security@ghost.org --- Credits: Aden Yap Chuen Zhen, BAE Systems Applied Intelligence (Malaysia)
- BIT-ghost-2021-39192Privilege escalation: all users can access Admin-level API keys2024-03-06vendor · osvUS
Ghost is a Node.js content management system. An error in the implementation of the limits service between versions 4.0.0 and 4.9.4 allows all authenticated users (including contributors) to view admin-level API keys via the integrations API endpoint, leading to a privilege escalation vulnerability. This issue is patched in Ghost version 4.10.0. As a workaround, disable all non-Administrator accounts to prevent API access. It is highly recommended to regenerate all API keys after patching or applying the workaround.
also known as (5)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (7)
External citations — patches, advisories, analysis.
- https://github.com/TryGhost/Ghost/releases/tag/v4.10.0cnnvd
- https://github.com/TryGhost/Ghost/security/advisories/GHSA-j5c2-hm46-wp5ccnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2021-39192cnnvd
- https://github.com/TryGhost/Ghost/releases/tag/v4.10.0enisa_euvd
- https://github.com/TryGhost/Ghost/security/advisories/GHSA-j5c2-hm46-wp5cenisa_euvd
- https://github.com/TryGhost/Ghost/releases/tag/v4.10.0Release NotesThird Party Advisorynvd
- https://github.com/TryGhost/Ghost/security/advisories/GHSA-j5c2-hm46-wp5cThird Party Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan