CVE-2021-3619
lowpriority · track · 19EPSS 0.006 · 47 %ileEUUSEPSS · scored 2026-10-28
Rapid7 Velociraptor 0.5.9 and prior is vulnerable to a post-authentication persistent cross-site scripting (XSS) issue, where an authenticated user could abuse MIME filetype sniffing to embed executable code on a malicious upload. This issue was fixed in version 0.6.0. Note that login rights to Velociraptor is nearly always reserved for trusted and verified users with IT security backgrounds.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 3.5–4.8
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (2)
Products and version ranges known to be affected.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (7)
External citations — patches, advisories, analysis.
- https://github.com/Velocidex/velociraptor/pull/1118cnnvd
- https://github.com/Velocidex/velociraptor/releases/tag/v0.6.0cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2021-3619cnnvd
- https://github.com/Velocidex/velociraptor/pull/1118enisa_euvd
- https://github.com/Velocidex/velociraptor/releases/tag/v0.6.0enisa_euvd
- https://github.com/Velocidex/velociraptor/pull/1118PatchThird Party Advisorynvd
- https://github.com/Velocidex/velociraptor/releases/tag/v0.6.0Third Party Advisorynvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan