CVE-2021-32809

lowpriority · track · 22EPSS 0.012 · 68 %ileEURUUS
grimoire priorityP3 · Track
Exploitable?
—
no known exploitation
Likely / severe?
1.19% (68th) EPSS
CVSS 3.5 · low
Is it mine?
21 products
Check your exposure
Who says so?
5 sources
cnnvd · enisa_euvd · fstec_bdu · nvd

EPSS · scored 2026-10-27

ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.

01

cvss

Technical severity, 0–10. One row per scoring source.

5.4
010

base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 3.5–5.4

v2.03.5lowAV:N/AC:M/Au:S/C:N/I:P/A:Nprimary · NVD / NIST USexploitability 6.8 · impact 2.9
v3.15.4mediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:Nprimary · NVD / NIST USexploitability 2.3 · impact 2.7
v3.15.4mediumAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:Nsecondary · FSTEC (BDU) RU
v3.14.6mediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:Nsecondary · ENISA EU
v3.14.6mediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:Nsecondary · security-advisories@github.comexploitability 2.1 · impact 2.5
v3.14.6mediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:Nsecondary · OSV
v3.15mediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:Usecondary · CVSS-BT (t0sche)
02

weaknesses

The CWE weakness classes this flaw belongs to.

03

affected products (21)

Products and version ranges known to be affected.

showing 20 of 21
04

advisories (1)

Vendor and ecosystem advisories describing this.

  • GHSA-7889-rm5j-hpggClipboard feature vulnerability allowing to inject arbitrary HTML into the editor using paste functionality2021-08-23ghsa · osvUS

    ### Affected packages The vulnerability has been discovered in [clipboard](https://ckeditor.com/cke4/addon/clipboard) plugin. All plugins with [clipboard](https://ckeditor.com/cke4/addon/clipboard) plugin dependency are affected: * [clipboard](https://ckeditor.com/cke4/addon/clipboard) * [pastetext](https://ckeditor.com/cke4/addon/pastetext) * [pastetools](https://ckeditor.com/cke4/addon/pastetools) * [widget](https://ckeditor.com/cke4/addon/widget) * [uploadwidget](https://ckeditor.com/cke4/addon/uploadwidget) * [autolink](https://ckeditor.com/cke4/addon/autolink) * [tableselection](https://ckeditor.com/cke4/addon/tableselection) ### Impact A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. ### Patches The problem has been recognized and patched. The fix will be available in version 4.16.2. ### For more information Email us at security@cksource.com if you have any questions or comments about this advisory. ### Acknowledgements The CKEditor 4 team would like to thank Anton Subbotin ([skavans](https://github.com/skavans)) for recognizing and reporting this vulnerability.

05

also known as (4)

Other names and identifiers for this entity.

06

sources

Which sources assert this record, and when.

published 2021-08-12modified 2026-06-17
08

references (23)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan