CVE-2021-32669

lowpriority · track · 22EPSS 0.006 · 49 %ileEURUUS
grimoire priorityP3 · Track
Exploitable?
—
no known exploitation
Likely / severe?
0.60% (49th) EPSS
CVSS 3.5 · low
Is it mine?
21 products
Check your exposure
Who says so?
5 sources
cnnvd · enisa_euvd · fstec_bdu · osv

EPSS · scored 2026-10-27

TYPO3 is an open source PHP based web content management system. Versions 9.0.0 through 9.5.28, 10.0.0 through 10.4.17, and 11.0.0 through 11.3.0 have a cross-site scripting vulnerability. When settings for _backend layouts_ are not properly encoded, the corresponding grid view is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability. TYPO3 versions 9.5.29, 10.4.18, 11.3.1 contain a patch for this vulnerability.

01

cvss

Technical severity, 0–10. One row per scoring source.

6.4
010

base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 3.5–6.4

v2.03.5lowAV:N/AC:M/Au:S/C:N/I:P/A:Nprimary · NVD / NIST USexploitability 6.8 · impact 2.9
v3.15.4mediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:Nprimary · NVD / NIST USexploitability 2.3 · impact 2.7
v3.15.4mediumAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:Nsecondary · FSTEC (BDU) RU
v3.16.4mediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:Nsecondary · ENISA EU
v3.16.4mediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:Nsecondary · security-advisories@github.comexploitability 1.2 · impact 5.2
v3.16.4mediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:Nsecondary · OSV
v3.15mediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:Usecondary · CVSS-BT (t0sche)
02

weaknesses

The CWE weakness classes this flaw belongs to.

03

affected products (21)

Products and version ranges known to be affected.

showing 20 of 21
04

advisories (2)

Vendor and ecosystem advisories describing this.

  • GHSA-rgcg-28xm-8mmwCross-Site Scripting in Backend Grid View2021-07-22ghsa · osvUS

    ### Problem Failing to properly encode settings for _backend layouts_, the corresponding grid view is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability. ### Solution Update to TYPO3 versions 8.7.41 ELTS, 9.5.28, 10.4.18, 11.3.1 that fix the problem described. ### Credits Thanks to TYPO3 core merger Oliver Bartsch who reported and fixed the issue.

  • BIT-typo3-2021-326692024-03-06vendor · osvUS

    TYPO3 is an open source PHP based web content management system. Versions 9.0.0 through 9.5.28, 10.0.0 through 10.4.17, and 11.0.0 through 11.3.0 have a cross-site scripting vulnerability. When settings for _backend layouts_ are not properly encoded, the corresponding grid view is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability. TYPO3 versions 9.5.29, 10.4.18, 11.3.1 contain a patch for this vulnerability.

05

also known as (6)

Other names and identifiers for this entity.

06

sources

Which sources assert this record, and when.

published 2021-07-20modified 2026-06-17
08

references (9)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan