CVE-2021-29484

mediumpriority · track · 20EPSS 0.079 · 95 %ileEUUS
grimoire priorityP3 · Track
Exploitable?
—
no known exploitation
Likely / severe?
7.94% (95th) EPSS
CVSS 4.3 · medium
Is it mine?
4 products
Check your exposure
Who says so?
4 sources
cnnvd · enisa_euvd · osv · nvd

EPSS · scored 2026-10-27

Ghost is a Node.js CMS. An unused endpoint added during the development of 4.0.0 has left sites vulnerable to untrusted users gaining access to Ghost Admin. Attackers can gain access by getting logged in users to click a link containing malicious code. Users do not need to enter credentials and may not know they've visited a malicious site. Ghost(Pro) has already been patched. We can find no evidence that the issue was exploited on Ghost(Pro) prior to the patch being added. Self-hosters are impacted if running Ghost a version between 4.0.0 and 4.3.2. Immediate action should be taken to secure your site. The issue has been fixed in 4.3.3, all 4.x sites should upgrade as soon as possible. As the endpoint is unused, the patch simply removes it. As a workaround blocking access to /ghost/preview can also mitigate the issue.

01

cvss

Technical severity, 0–10. One row per scoring source.

6.8
010

base score 0–10 · higher = more severe · hover a vector to decode

v2.04.3mediumAV:N/AC:M/Au:N/C:N/I:P/A:Nprimary · NVD / NIST USexploitability 8.6 · impact 2.9
v2.04.1mediumAV:N/AC:M/Au:N/C:N/I:P/A:N/E:Fsecondary · CVSS-BT (t0sche)
v3.16.1mediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:Nsecondary · NVD / NIST USexploitability 2.8 · impact 2.7
v3.16.8mediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:Nsecondary · ENISA EU
v3.16.8mediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:Nsecondary · security-advisories@github.comexploitability 1.6 · impact 5.2
v3.16.8mediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:Nsecondary · OSV
02

weaknesses

The CWE weakness classes this flaw belongs to.

03

affected products (4)

Products and version ranges known to be affected.

04

advisories (2)

Vendor and ecosystem advisories describing this.

  • GHSA-9fgx-q25h-jxrgDOM XSS in Theme Preview2021-04-29ghsa · osvUS

    ### Impact An unused endpoint added during the development of 4.0.0 has left sites vulnerable to untrusted users gaining access to Ghost Admin. Attackers can gain access by getting logged in users to click a link containing malicious code. Users do not need to enter credentials and may not know they've visited a malicious site. Ghost(Pro) has already been patched. We can find no evidence that the issue was exploited on Ghost(Pro) prior to the patch being added. Self-hosters are impacted if running Ghost a version between 4.0.0 and 4.3.2. Immediate action should be taken to secure your site - see patches & workarounds below. ### Patches Fixed in 4.3.3, all 4.x sites should upgrade as soon as possible. As the endpoint is unused, the patch simply removes it. ### Workarounds - Log out of Ghost Admin - Suspend any users who cannot log out - Block access to `/ghost/preview` Example of how to block access in nginx: ``` location ~ /ghost/preview { rewrite ^(\/(.*\/)?ghost\/)(.*)$ $1 redirect; } ``` This redirects the endpoint to `/ghost/`, which mimics the behaviour after the patch is applied. ### References - [Forum Post](https://forum.ghost.org/t/critical-security-update-available-for-ghost-4-x/22290) ### For more information If you have any questions or comments about this advisory: * email us at security@ghost.org --- Credits: Paul Gerste, SonarSource (https://www.sonarsource.com/)

  • BIT-ghost-2021-29484DOM XSS in Theme Preview2024-03-06vendor · osvUS

    Ghost is a Node.js CMS. An unused endpoint added during the development of 4.0.0 has left sites vulnerable to untrusted users gaining access to Ghost Admin. Attackers can gain access by getting logged in users to click a link containing malicious code. Users do not need to enter credentials and may not know they've visited a malicious site. Ghost(Pro) has already been patched. We can find no evidence that the issue was exploited on Ghost(Pro) prior to the patch being added. Self-hosters are impacted if running Ghost a version between 4.0.0 and 4.3.2. Immediate action should be taken to secure your site. The issue has been fixed in 4.3.3, all 4.x sites should upgrade as soon as possible. As the endpoint is unused, the patch simply removes it. As a workaround blocking access to /ghost/preview can also mitigate the issue.

05

also known as (5)

Other names and identifiers for this entity.

06

sources

Which sources assert this record, and when.

published 2021-04-29modified 2026-06-17
08

references (15)

External citations — patches, advisories, analysis.

scry

Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.

Free scan