CVE-2021-28657
mediumpriority · track · 23EPSS 0.027 · 86 %ileDEEUUSEPSS · scored 2026-10-27
A carefully crafted or corrupt file may trigger an infinite loop in Tika's MP3Parser up to and including Tika 1.25. Apache Tika users should upgrade to 1.26 or later.
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (29)
Products and version ranges known to be affected.
- Oracle Fusion Middleware 11.1.1.5.0all versionscert_bundDEcpe:/a:oracle:fusion_middleware:11.1.1.5.0
- Oracle Fusion Middleware 12.2.1.3.0all versionscert_bundDEcpe:/a:oracle:fusion_middleware:12.2.1.3.0
- Oracle Fusion Middleware 12.2.1.4.0all versionscert_bundDEcpe:/a:oracle:fusion_middleware:12.2.1.4.0
- Oracle Fusion Middleware 12.2.2.0.0all versionscert_bundDEcpe:/a:oracle:fusion_middleware:12.2.2.0.0
- Oracle Fusion Middleware 14.1.1.0.0all versionscert_bundDEcpe:/a:oracle:fusion_middleware:14.1.1.0.0
- oracle communications messaging server= 8.1nvdUScpe:2.3:o:oracle:communications_messaging_server:*:*:*:*:*:*:*:*
advisories (3)
Vendor and ecosystem advisories describing this.
- WID-SEC-W-2024-1872IBM QRadar SIEM: Mehrere SchwachstellenDeutsch2021-07-25csaf · cert_bundDE
Ein entfernter anonymer oder authentifizierter Angreifer kann mehrere Schwachstellen in IBM QRadar SIEM ausnutzen, um vertrauliche Informationen offenzulegen, Sicherheitsmaßnahmen zu umgehen, Dateien zu manipulieren, einen Denial-of-Service-Zustand auszulösen und einen Cross-Site-Scripting-Angriff durchzuführen.
- WID-SEC-W-2024-2180Oracle Fusion Middleware: Mehrere SchwachstellenDeutsch2022-04-19csaf · cert_bundDE
Ein entfernter, anonymer oder lokaler Angreifer kann mehrere Schwachstellen in Oracle Fusion Middleware ausnutzen, um die Vertraulichkeit, Integrität und Verfügbarkeit zu gefährden.
- GHSA-567x-m4wm-87v8Infinite loop in Apache Tika2021-05-10ghsa · osvUS
A carefully crafted or corrupt file may trigger an infinite loop in Tika's MP3Parser up to and including Tika 1.25. Apache Tika users should upgrade to 1.26 or later.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (23)
External citations — patches, advisories, analysis.
- https://access.redhat.com/security/cve/cve-2021-28657cnnvd
- https://lists.apache.org/thread.html/r4cbc3f6981cd0a1a482531df9d44e4c42a7f63342a7ba78b7bff8a1b@%3Cnotifications.james.apache.org%3Ecnnvd
- https://lists.apache.org/thread.html/r915add4aa52c60d1b5cf085039cfa73a98d7fae9673374dfd7744b5a%40%3Cdev.tika.apache.org%3Ecnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2021-28657cnnvd
- https://security.netapp.com/advisory/ntap-20210507-0004/cnnvd
- https://vigilance.fr/vulnerability/Apache-Tika-overload-via-MP3Parser-35985cnnvd
- https://www.auscert.org.au/bulletins/ESB-2021.2197cnnvd
- https://www.auscert.org.au/bulletins/ESB-2021.2525cnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan