CVE-2021-23839
mediumpriority · track · 16OT risk · elevatedEPSS 0.030 · 87 %ileDEEUUSEPSS · scored 2026-10-26
OpenSSL 1.0.2 supports SSLv2. If a client attempts to negotiate SSLv2 with a server that is configured to support both SSLv2 and more recent SSL and TLS versions then a check is made for a version rollback attack when unpadding an RSA signature. Clients that support SSL or TLS versions greater than SSLv2 are supposed to use a special form of padding. A server that supports greater than SSLv2 is supposed to reject connection attempts from a client where this special form of padding is present, because this indicates that a version rollback has occurred (i.e. both client and server support greater than SSLv2, and yet this is the version that is being requested). The implementation of this padding check inverted the logic so that the connection attempt is accepted if the padding is present, and rejected if it is absent. This means that such as server will accept a connection if a version rollback attack has occurred. Further the server will erroneously reject a connection if a normal SSLv2 connection attempt is made. Only OpenSSL 1.0.2 servers from version 1.0.2s to 1.0.2x are affected by this issue. In order to be vulnerable a 1.0.2 server must: 1) have configured SSLv2 support at compile time (this is off by default), 2) have configured SSLv2 support at runtime (this is off by default), 3) have configured SSLv2 ciphersuites (these are not in the default ciphersuite list) OpenSSL 1.1.1 does not have SSLv2 support and therefore is not vulnerable to this issue. The underlying error is in the implementation of the RSA_padding_check_SSLv23() function. This also affects the RSA_SSLV23_PADDING padding mode used by various other functions. Although 1.1.1 does not support SSLv2 the RSA_padding_check_SSLv23() function still exists, as does the RSA_SSLV23_PADDING padding mode. Applications that directly call that function or use that padding mode will encounter this issue. However since there is no support for the SSLv2 protocol in 1.1.1 this is considered a bug and not a security issue in that version. OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.0.2y (Affected 1.0.2s-1.0.2x).
remediations
Vendor fix, mitigation, or workaround guidance, as published by each source.
A vendor fix is available.
- FixedSINEC INSsiemens_psirt
Update to V1.0 SP2 or later version
https://support.industry.siemens.com/cs/ww/en/view/109812610/ - FixedSINEC INScisa_csaf_ot
Update to V1.0 SP2 or later version
https://support.industry.siemens.com/cs/ww/en/view/109812610/
cvss
Technical severity, 0–10. One row per scoring source.
base score 0–10 · higher = more severe · hover a vector to decode⚠ sources disagree · low–medium · 3.4–4.3
ssvc
A stakeholder decision — act, attend, or track — from exploitation and impact.
weaknesses
The CWE weakness classes this flaw belongs to.
affected products (72)
Products and version ranges known to be affected.
- Avaya Aura Application Enablement Servicesall versionscert_bundDEcpe:/a:avaya:aura_application_enablement_services:-
advisories (4)
Vendor and ecosystem advisories describing this.
- SSA-637483SSA-637483 Third-Party Component Vulnerabilities in SINEC INS before V1.0 SP22022-09-13csaf · siemens_psirtDE
Multiple vulnerabilities affecting various third-party components of SINEC INS before V1.0 SP2 could allow an attacker to cause a denial of service condition, disclose sensitive data or violate the system integrity. Siemens has released an update for the SINEC INS and recommends to update to the latest version.
- WID-SEC-W-2022-0669OpenSSL: Mehrere SchwachstellenDeutsch2021-02-16csaf · cert_bundDE
Ein entfernter, anonymer oder lokaler Angreifer kann mehrere Schwachstellen in OpenSSL ausnutzen, um Sicherheitsvorkehrungen zu umgehen oder einen Denial of Service Zustand herzustellen.
- WID-SEC-W-2026-0180Dell Data Protection Advisor: Mehrere SchwachstellenDeutsch2026-01-20csaf · cert_bundDE
Ein Angreifer kann mehrere Schwachstellen in Dell Data Protection Advisor ausnutzen, um beliebigen Code auszuführen, einen Denial-of-Service-Zustand zu erzeugen, Sicherheitsmaßnahmen zu umgehen und nicht näher spezifizierte Angriffe zu starten.
- ICSA-22-258-05Siemens SINEC INS2022-09-13icsa · cisa_csaf_otUS
Multiple vulnerabilities affecting various third-party components of SINEC INS before V1.0 SP2 could allow an attacker to cause a denial of service condition, disclose sensitive data or violate the system integrity. Siemens has released an update for the SINEC INS and recommends to update to the latest version.
also known as (3)
Other names and identifiers for this entity.
sources
Which sources assert this record, and when.
references (57)
External citations — patches, advisories, analysis.
- https://bugzilla.redhat.com/show_bug.cgi?id=1930294Patchcnnvd
- https://cert-portal.siemens.com/productcert/pdf/ssa-637483.pdfcnnvd
- https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=30919ab80a478f2d81f2e9acdcca3fa4740cd547cnnvd
- https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44846cnnvd
- https://nvd.nist.gov/vuln/detail/CVE-2021-23839cnnvd
- https://security.netapp.com/advisory/ntap-20210219-0009/cnnvd
- https://us-cert.cisa.gov/ics/advisories/icsa-22-258-05cnnvd
- https://vigilance.fr/vulnerability/OpenSSL-1-0-2-read-write-access-via-SSLv2-Rollback-Protection-Bypass-34596cnnvd
Attackers weaponise vulnerabilities like this against internet-exposed services. See what is exposed on your perimeter with a free passive scan.
Free scan